Network visible but unable to connect


I have been using Ubuntu for about 1.5 years, Mint for the last few months. Both have worked out of the box with no tweaking necessary including wifi.

I fancied trying a different flavour so I downloaded the openSUSE 11 KDE live disc a couple of days ago and have been playing a bit. I quite like it and would like to try a full install only i cannot get my internet connection to work.

The network is visible on the wifi applet type thing on the taskbar but i cannot get a working connection. I enter my WPA key, click OK or apply. Theres nothing to indicate that something is wrong other than i cannot access webpages. When i go back to the wifi applet the WPA key field is blank. I have also tried setting up the connection from scratch with no success.

Any ideas?

Have you looked at the first 2 threads in the wireless section: Wireless - openSUSE Forums
If this doesn’t help and you don’t have any ubuntu ‘non-shared’ hardware solutions (ie ubuntu have got it working but aren’t sharing the knowledge) it should work.
If all else fails and there are no ubuntu ‘funnies’, check the settings in ubuntu/mint and transfer them to opensuse.