Network periodic disconnection?


Every few minutes, my network disconnects. If I unplug the cable and plug it back again, data start flowing again… but after a few minutes, it’s back to stopped.

I read there is a default timeout somewhere, but couldn’t find it.

I’m running openSUSE 10.3.

Feature Wishlist - openSUSE

What’s this “Internet connection timeout”? Where do you find it? I’d like to test if that’s the problem…

You’ll find Idle Time-Out in your internet connection parameters (i.e. DSL, ISDN or Modem) in Yast. Note that this setting is useless when your behind a router. Because it only times out when there’s no network traffic, I don’t think that Idle Time-Out causes your problem.

Click on “Feature Wishlist”

I have now tested the connection at two different places, and the problem keeps happening – after a few minutes, the eth0 connection drops off. If I unplug it, and plug it back again, it goes back to life.

I am using the r8169 module – might that be the cause?

I changed over to r8168 (provided by Realtek) and even blacklisted r8169, but it made no difference…

im having exactly the same problem using dial-up Broadband

In the dial-up case it makes sense to have a look at the “Idle Time-Out” setting, see post 3 in this thread. The default setting is a disconnect after 300 seconds of no traffic. Set “Idle Time-Out” to 0 if you want to stay connected all the time.

And thats exactly what i did. With no success.

Following a suggestion by Swerdna (thanks, again, to him!) I tried Realtek’s r8169 driver instead of r8168 – and it worked! I downloaded it from Realtek’s site, and installed it according to the “readme” included instructions.

What I do wonder now is… why isn’t that driver included in OpenSUSE, instead of the current buggy one?!

Im already using r8169 :frowning: