Network name resolution

Hello,

It seems that my Computers name isn’t resolved properly in the network,
The router certainly only knows my Mac and IP address.
Weirdly the Macintosh and Windows machines in our network all
send their names and are known by them to the router.

When I run Wireshark my name is often resolved to something like:
IntelCore_9f…

On my machine it’s name is shown appropriately and I set the NETBiosname
in the samaba settings but it didn’t change anything.

Where can I set the name of the machine so that it is known
to others in the network (ie the router and other machines) ??

If you use Samba, then there are two places where a PC name is set. The primary location is in Yast/Network Devices/Network Settings/Hostname DNS/Hostname. Be aware than making the Samba netbios name the same as the Linux hostname can cause Samba to not work properly in some cases. If you use the Network Manager and not ifup, you will be told to use that program (network manager), but the hostname comes from this screen as indicated. You might need to disable the Network Manager, reverting back to ifup, long enough to change your PC name. Reboot if you make any changes here.

Thank You,

I strongly disagree that having the netbios name and the hostname the same can cause Samba to not work properly. It’s OK (and in fact preferable IMO) to have the hostname and the Samba netbios names the same.

You set the netbios name in the [global] stanza of the Samba config file. Easiest is to run this command to edit it:

  • Gnomers use this command: gnomesu gedit /etc/samba/smb.conf
  • KDE use this command: kdesu kwrite /etc/samba/smb.conf

You set the hostname in Yast → Network Devices → Network Settings → Hostname/DNS → Hostname (as mentioned by dmcdaniel3).

+1. They are distinct protocols anyway, NMB and DNS.

To mention another factor, with routers that have a DHCP+DNS server builtin, what generally happens is that the machine sends it the preferred hostname in the DHCP request, and the router then adds this name to its tables so that other hosts can reach the machine that just came onto the network. There’s a setting in YaST > Network Setttings for the preferred name to send by DHCP, look for it.

My statement “Be aware that making the Samba netbios name the same as the Linux hostname can cause Samba to not work properly in some cases” was based on actual problems I encountered using SuSELinux 10 and the version of Samba used then and may no longer apply today, but I did say “some cases”. While searching on the subject I ran into this paragraph that seemed to put a lot of acronyms in one place on the subject:

“MS Windows networking is thus predetermined to use machine names for all local and remote machine message passing. The protocol used is called Server Message Block (SMB), and this is implemented using the NetBIOS protocol (Network Basic Input/Output System). NetBIOS can be encapsulated using LLC (Logical Link Control) protocol in which case the resulting protocol is called NetBEUI (Network Basic Extended User Interface). NetBIOS can also be run over IPX (Internetworking Packet Exchange) protocol as used by Novell NetWare, and it can be run over TCP/IP protocols in which case the resulting protocol is called NBT or NetBT, the NetBIOS over TCP/IP.”

This was part of a work on Samba and Windows integration at the url:

Chapter 29. Integrating MS Windows Networks with Samba

You may find it interesting to read if you use Samba.

Thank You,

On Mon July 5 2010 12:16 pm, jdmcdaniel3 wrote:

>
> My statement “Be aware that making the Samba netbios name the same as
> the Linux hostname can cause Samba to not work properly in some cases”
> was based on actual problems I encountered using SuSELinux 10 and the
> version of Samba used then and may no longer apply today, but I did say
> “some cases”. While searching on the subject I ran into this paragraph
> that seemed to put a lot of acronyms in one place on the subject:
>
<snip>

The only real problem, is that the Netbios name is limited to 15 characters
(Unicode letters/numbers plus a few symbols). The DNS host name can be much
longer. In this case, Windows (and Samba by default) truncates the hostname
to 15 characters.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

That’s the only case of interest these days. NetBEUI is pretty dead, NetBIOS over IPX would be confined to IPX networks and I think many of them have switched to TCP anyway.

My statement “Be aware that making the Samba netbios name the same as the Linux hostname can cause Samba to not work properly in some cases” was based on actual problems I encountered using SuSELinux 10 and the version of Samba used then and may no longer apply today, but I did say “some cases”.

It’s not a good idea to use examples from obsolete versions of openSUSE and obsolete versions of Samba, from five years ago, to advise ppl on Samba. I recall that for 10.0 the default with Samba if one didn’t specify a netbios name was for Samba to adopt the hostname as the netbios name. That’s also the case today. I’ll just reiterate for passers by that it’s OK to use the hostname for the netbios name, and particularly so for new users because that reduces possible confusion IMO.