Network Manager now not working after update today

I did a zypper dup on my TW KDE system today and after a reboot Network Manager behaves strangely and I am unable to connect to any wireless connection which was perfectly OK prior to the update. When I open the systray MN widget I can see it trying to connect, it then removes all the visible connections and after a few moments it displays them again and tries to connect to the original one, it loops like this consistently. I tried booting off my older kernel but same happens. I can switch to wicked and after some messing around eventually it the network connects to the same SSID that NM was trying. I have also been unable to get static IP to work in wicked with specified DNS servers but that may be me as I am not familiar with wicked. I like having a widget to see what is going on which is why I use NM. NM is at V1.12.2.

I’ve not found anything in the journal which might indicate what is happening with NM. Has anyone any suggestions as to what went wrong or how I might progress getting NM to work again please?


Sounds related: NetworkManager error "corrupted double-linked list" when starting openvpn - Network/Internet - openSUSE Forums

What you see is the wifi device turning on and off and on again. What happens if you boot a previous kernel?
And … btrfs ?

As a test I deleted openvpn as I dont use it. I then switched back to Network Manager and it all works fine now using it. So it seems that openVPN is the cause of the issue.

I did try the older kernel but it had no effect on this issue. I dont use BTRFS and never have, tried it once and had a huge problem so never again!


Well although I am now connected it is not behaving as it should. I am unable to select a different connection in the NM widget and get a successful connection so it disconnects (after authentication but before getting IP) and reconnects to the previously used connection. I have checked the settings for each one and there are as they should be.

So there is still a problem. Nothing shows in the journal when doing this.


Not with the last “dup” but a few “dups” ago, I had an issue where I was not able to connect to a network or it would just have crazy behavior with reconnects. What I recommend you do is delete the network settings out of network manager, reboot the machine and re-add those networks. I don’t know that this will certainly fix your problem but it fixed my problem after some trial and error. I don’t know that it was certainly the issue or not but it seemed to have cleared up the issue.

I also say “reboot” the machine because restarting the network service doesn’t always help

sudo systemctl restart network

This has worked better for me.

sudo systemctl stop network

wait a bit

sudo systemctl start network

It is as though something is lodged in memory and a reboot is required to flush it out. I didn’t have the patience to figure it out at the time and it hasn’t resurfaced since.

Give it a try and see if this helps out.

Hope that helps.

Funnily enough I just did pretty much that and it does seem to have improved it. Still not completely sure it’s solved everything so a bit more testing to do.


It will be interesting to find out whether or not it solves your problem. I can’t say for sure mine is completely solved but it hasn’t been a “problem” in well over a month.