Network Manager failed connection

Using XFCE.

I have booted 15.3 several times with Network Manager connecting properly via eth0 (no wi-fi). Then after the most recent update when I booted there were two Network Manager icons in my panel and it would not connect. 15.2 on the same box boots and connects just fine.

Suggestions will be appreciated.

What does **ip a **say? Is your ethernet link up and available?
Tried (as root) **systemctl restart NetworkManager.service **?
I also run 15.3 with an eth link and it connects without errors…

Just installed 15.3. Could someone please point me to a sticky on how to connect via cable. NetworkManager tells me I am connected to etho but I can’t ping any address.

Hi
What does it say in Network Manager about the connection?


ip addr
ip route

 # ip a1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e0:d5:5e:29:7a:f8 brd ff:ff:ff:ff:ff:ff
    altname enp3s0
    inet 192.168.2.53/24 brd 192.168.2.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::e2d5:5eff:fe29:7af8/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

I executed “systemctl stop NetworkManager.service” and that worked, but when I invoked “systemctl restart NetworkManager.service” two icons of NetworkManager popped up and told me I was connected to eth0 but I couldn’t ping any address. The hardware is fine because Ubuntu connects without a problem.

<br>
<br>

 # ip a1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000<br>
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00<br>
    inet 127.0.0.1/8 scope host lo<br>
       valid_lft forever preferred_lft forever<br>
    inet6 ::1/128 scope host <br>
       valid_lft forever preferred_lft forever<br>
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000<br>
    link/ether e0:d5:5e:29:7a:f8 brd ff:ff:ff:ff:ff:ff<br>
    altname enp3s0<br>
    inet 192.168.2.53/24 brd 192.168.2.255 scope global noprefixroute eth0<br>
       valid_lft forever preferred_lft forever<br>
    inet6 fe80::e2d5:5eff:fe29:7af8/64 scope link noprefixroute <br>
       valid_lft forever preferred_lft forever

<br>
<br>
I executed “systemctl stop NetworkManager.service” and that worked, but when I invoked “systemctl restart NetworkManager.service” two icons of NetworkManager popped up and told me I was connected to eth0 but I couldn’t ping any address. The hardware is fine because Ubuntu connects without a problem.

I should mention that I had exactly the same problem on another box yesterday and when I did a zypper up it went away. Not this one.

 # ip addr1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether e0:d5:5e:29:7a:f8 brd ff:ff:ff:ff:ff:ff
    altname enp3s0
    inet 192.168.2.53/24 brd 192.168.2.255 scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::e2d5:5eff:fe29:7af8/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

localhost:/home/ion # ip route
default via 192.168.2.1 dev eth0 proto dhcp metric 20100 
192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.53 metric 100 

You have an address assigned to eth0. It would also be useful to confirm default route. Do you possibly have wicked and NetworkManager active concurrently?

BTW, I note that you have a duplicate thread for this…
https://forums.opensuse.org/showthread.php/555003-No-ethernet

Best to keep your discussion in one place really. I can close one out or merge the threads.

Please do so, as it’s confusing me too.

I don’t see how that’s possible since YaST only allows one or the other.

All the same it can be checked with

sudo systemctl status wicked
sudo systemctl status NetworkManager

Can you ping a well known internet address?

ping 8.8.8.8

If that checks out, ping by name

ping google.com

Done now…

As requested. I can’t ping any address or I.P.

 # systemctl status wicked● wicked.service - wicked managed network interfaces
     Loaded: loaded (/usr/lib/systemd/system/wicked.service; disabled; vendor preset: disabled)
     Active: inactive (dead)
localhost:/home/ion # systemctl status NetworkManager
● NetworkManager.service - Network Manager
     Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
    Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
             └─NetworkManager-ovs.conf
     Active: active (running) since Fri 2021-06-04 16:45:03 CDT; 1h 3min ago
       Docs: man:NetworkManager(8)
   Main PID: 2125 (NetworkManager)
      Tasks: 4 (limit: 4915)
     CGroup: /system.slice/NetworkManager.service
             ├─2125 /usr/sbin/NetworkManager --no-daemon
             └─2148 /sbin/dhclient -d -q -sf /usr/lib/nm-dhcp-helper -pf /run/NetworkManager/dhclient>


Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3185] device (eth0): >
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3257] device (eth0): >
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3265] device (eth0): >
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3285] manager: Networ>
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3339] manager: Networ>
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.3346] policy: set 'et>
Jun 04 16:45:10 localhost.localdomain dhclient[2148]: Timeout too large reducing to: 2147483646 (TIME>
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.7820] device (eth0): >
Jun 04 16:45:10 localhost.localdomain NetworkManager[2125]: <info>  [1622843110.7850] manager: startu>
Jun 04 16:45:20 localhost.localdomain NetworkManager[2125]: <info>  [1622843120.7923] policy: set-hos> 

Ok, that confirms NetworkManager is active. Can you ping your gateway ok? Can you ping an Internet address successfully?

Not a firewall issue at play?

Which issue exactly? There are two likely independent questions here - double icon for NetworkManager and “cannot connect”. Double icon is likely Xfce configuration issue (same applet added twice?) and is better asked with clear subject on Applications forum (or I’d say such questions are better asked on dedicated forums for software in question). “Cannot connect” is absolutely unclear and the only evidence that was provided shows IP address and default router. It may be DNS issue, it may be something else but unless “cannot connect” will be followed by description what user actually tried to do, what result user expected and what result user observed we can continue to play game of riddles till doomsday.

Let me chime in with some experience with the Network Manager.

I am connected via an ADSL router and if for some reason that ADSL connection is down I have a hard time to debug things and realize things. The first thing I typically want is to have a look at the web interface of the ADSL box but that typically does not work while I am using the web browser with the IP address as URL.

The problem seems to be that the Network Manager detects there is no connection and brings the interface down to bring it up some thing later up again to see if that fixes the problem and that continues but that interferes with my efforts to connect to the ADSL box. What “ip a” shows at one time is not necessary true later.

Took now the time to find a way around and see that can be done by changing the IPv4/IPv6 method and think next time I will try Link-Local or Shared to other computers for the debug.

https://paste.opensuse.org/images/34260658.png

I like the Network Manager but debugging is different than I was used to.

I’ve been using the NetworkManager for years in multiple network environments, (wireless and wired connectivity, VPNs etc) without issue. Not clear to me what problem the OP is describing, although they claim they can’t ping the gateway, or internet addresses successfully (despite demonstrating ip address and default route).

https://forums.opensuse.org/showthread.php/553065-Difference-in-network-access?p=3023724#post3023724

I have had problems with Network Manager on a new install of 15.3. I set the option on install to use Network Manager but on boot up wicked was active. In order to get N/Mgr to work I had to disable wicked , enable N/Mgr and start it and now it is all fine using N/Mgr. So there is something wrong on install of 15.3.

Stuart