Network Icon missing in System Tray (KDE)!

In the LiveCD there is an Icon. You can see it left of this pic.

This Icon is missing in a FULL INSTALL of openSuSE, how can I make it shown up. :\

I have KDE Desktop.
pls help, thx

Yes, I noticed that.

I had installed 11.4, but had retained “/home” as it was, with all of the old settings.

I fixed the problem by deleting $HOME/.kde4 and then configuring from scratch.

You might be able to do it with the panel settings.

Unlock widgets.
Right click on the panel. You should see “panel options.” Move your mouse over that, and there should be a menu where you can select “panel settings.”
No move the mouse to the panel settings bar just above the system tray. There should be a system tray configuration option. Click on that.

Then make sure that you check the setting for “Network Management.”

Finally, you can lock widgets once again if you like to have them locked.

Hash: SHA1

The live CD has been configured to use networkmanager and have the
plasmoid client for that, but the DVD installation detect if you have a
laptop to use it or a desktop to use the ifup method. Maybe you’re not
using networkmanager…


Microsoft Windows is like air conditioning
Stops working when you open a window.
Version: GnuPG v2.0.15 (GNU/Linux)
Comment: Using GnuPG with SUSE -


there is no network management in the system tray settings
PS: i also checked this settings

what is this machine you’re running openSUSE on?

This depends on whether your system is configured to use “ifup” for networking, or “Networkmanager”. A PC would normally use “ifup” to start the network config at boottime, a laptop would use the Networknanager since the user will establish a connection whereever he comes by himself.
You can check the settings in Yast - Network - Networksettings

With a default KDE install particularly if you’re installing on a laptop, Network Manager should be installed by default.

If that is the case but Network Manager isn’t running, at least check whether it can be invoked and maybe not configured to startup and display in the tray by doing the following:

  1. KDE Application Launcher Button > Run Command… > “knetworkmanager” (without the quotes)

  2. If the Network Manager icon then displays in the tray, lft-click “Manage Connections”

  3. Click “Other” in the left navigation pane

  4. Check “show tray icon” if it’s not already checked


i fixed the problem by doing this:

open YaST

goto Network/Network Settings
and change from traditional to use network manager :wink:
and now the icon is here and all works fine

I use a laptop and I had to manually install NetworkManager-kde4 which required me to remove plasmoid-networkmanagement in order to have an icon in the system tray instead of a plasmoid.

Then I ran knetworkmanager to start it. A re-login may be required for the settings to take place.