Network icon in KDE not displaying correctly.

I installed opensuse 13.2 KDE today and i noticed that my network icon on the right side of the panel is displaying my network as not connected. The network is working fine but this is irritating me to no end. This is not a big issue, but i am wondering if there is fix to this?

thank you.

—System specs if needed—

motherboard: ga-990fxa-ud3 rev 4.0 (iommu enabled)
CPU: AMD FX-8350 black edition
Graphics card: EVGA nvidia GTX 770 2GB
RAM: 16GB kingston hyper-x DDR3 1600mhz

No. It is not displaying that you are not connected, it is in fact telling you that NetworkManager is not running. Hover over the icon and you will see.
This is just a frontend to NetworkManager, it won’t work if you use Wicked instead.

The network is working fine but this is irritating me to no end. This is not a big issue, but i am wondering if there is fix to this?

There are several ways:

  • Switch to NetworkManager in YaST->Network Devices->Network Settings->Global Options. The icon should then show your network fine and allow you to connect/disconnect and configure your network connections.
  • Hide the icon or disable it completely in the System Tray Settings (you reach them by right-clicking on the small up-arrow in the system tray that shows the hidden icons). You can enable/disable it in “Display”, or you can set it to “Hidden” in “Entries” (the default is “Automatic” which means it is always displayed in the case of the networkmanagement icon)
  • Uninstall the package “plasma-nm” and all its dependencies

Please note that if you don’t use NetworkManager, you have to use YaST to configure your connections.

If you do want to have a network icon in the system tray even without NetworkManager, try out “knemo”. It’s not installed by default, but is included in the distribution. Install it with YaST or zypper, and it should be started automatically on login, there will even be a configuration module in “Configure Desktop”/“Systemsettings”.
This will only show the state though, you cannot configure the network with it or connect/disconnect.

wolfi323, thanks a bunch. I’m at work right now so ill have to give this a try when i get home tonight.


Ok i finnaly got around to giving this a go. The first option (Switch to NetworkManager in YaST->Network Devices->Network Settings->Global Options. The icon should then show your network fine and allow you to connect/disconnect and configure your network connections.) fixed the issue perfectly. Thanks you very much wolfi323.

You’re welcome.

Actually this hasn’t changed in years. In openSUSE ifup (now its replacement Wicked) is used by default, unless a wireless device is detected during installation. In the latter case NetworkManager was enabled to make setting up a wireless connection easier.

It’s just that the old plasmoid-networkmanagement used upto 13.1 hid its icon automatically when NetworkManager is not running, whereas the new plasma-nm does not.
Btw, this will be different in Plasma 5, there plasma-nm will be loaded automatically when NetworkManager is running, and not loaded when it is not (and even unloaded when you quit NetworkManager).
As this only got possible through a new feature in Plasma (DBUS-activation of plasmoids), this won’t be possible in KDE4 any more though, unfortunately. (and you would have to make huge changes to plasma-nm to make it hide its icon by itself, this won’t happen either I guess)

>:) I have a similar issue with my newly updated server. When running 13.1 networkmanager was running correctly, I had full control over settings and my server had internet access as well as LAN access. After upgrading (fresh install or update) to 13.2, whenever I use Wicked, i have full access to network settings, but only the LAN connection is available, internally. Disabling Wicked and going back to NetworkManager, all settings for configuring NIC are grayed out, message states network is disabled but I have WAN and LAN access. I need to be able to remote access the server, have my website up ASAP, so any help will be greatly appreciated.

Charles.

UPDATE:

Now I have Wicked running, NetworkManager is not displaying status on task manager, and I have two different IP addresses showing up with improper subnets.

  1. 192.168.1.13/24 LinuxServer
  2. 192.168.1.17/24 LinuxServer

This should be assigned as follows:

  1. 192.168.1.13 255.255.255.0 LinuxServer

I am not able get this changed, nor can I update the IP information (and have it ‘stick’) at this point. Any ideas?

Yes. For the NetworkManager applet to work, you need to use NetworkManager, not wicked, as I explained already in this thread.

So like I wrote already, enter YaST->Network Devices->Network Settings->Global Options, and choose “NetworkManager” there instead of “Wicked Services”.
As you had it working before with NetworkManager, you should get it working again the same I’d say.

UPDATE #2:

Learning new things as I go today… Thankfully.

I have discovered that CIDR (Classless Inter-Domain Routing) network addressing is being notated by Wicked, over traditional by NetworkManager. This link http://www.ripe.net/internet-coordination/press-centre/understanding-ip-addressing shows a good table representation of the reason for the /24 suffix. I still am at a loss for Wicked’s use of multiple IP address.

To restore internet access, I had to manually add in DNS information, adjust IPv4 settings and specify FQHS information. This is a departure from NetworkManager operations, from what I have been able to use in the past. Also, I can find very limited information on Wicked, it seems that documentation is almost non-existent. I would imagine if this were to be the new replacement for NetworkManager they would have at least provided a decent amount of documentation to back it up.

It will come.

An overview
https://github.com/openSUSE/wicked

You misunderstand something.
It is not the new replacement for NetworkManager, it is a replacement for the old ifup.

And as I wrote already, NetworkManager is still there like it was in earlier openSUSE versions.
ifup has been replaced by Wicked.

Thankfully I have my server up and working for now, and things are running normally today. I have followed your recommendations to the letter, checked to make sure NetworkManager service was selected and attempt to adjust network settings. Every time I try and use NetworkManager all options to adjust network settings remain grayed out, no network connections to the outside can be made.

The only time I can have my server linked to WAN resources:

  1. Ensure Wicked is selected in Yast Network Settings
  2. Disable NetworkManager service via terminal commands
  3. Reboot the server
  4. Manually set up Network Services
  • Add FQDN in hosts, check in terminal
  • Set static IP via Yast
  • Setup DNS servers (LAN and WAN) via Yast

Once this has been completed, WAN access is restored and server functions normally. At this point I am considering removing (uninstalling) NetworkManager completely, both at time of install, and on machines that have already updated, if it would be better in the long run. The only caveat to this would be my lack of knowledge on whether this would “break” networking services.

Any thoughts?

I should add this - just for good measure ;-} …

I have been working with Windows Server '03 and '08 - both of which are a complete pain in the kiester to setup and maintain. Compared to that HEADACHE, dealing with this small issue in OpenSUSE is much less annoying. All things considered - Linux in general and OpenSUSE in particular are much more stable, and IMO a better choice for mission critical servers, home NAS boxes and even desktop use.

If I did not have to pay attention to Windows 7 and (ugh) Windows 8 notebooks for corporate reasons, every one of my computers would be running Linux. rotfl!

Where did you try to adjust network settings?
If you use NetworkManager, you can not configure it in YaST. You have to use your Desktop’s NetworkManager applet for that, and probably configure “Systemconnections” (now called “Allow other users to use this connection” or similar) to have them started at boot.

But as you used NetworkManager in the past, you should know that already, and I thought I made that clear already. Or did I misunderstand you?

If you want to get NetworkManager to work, you should probably post a screenshot of what exactly is greyed out.
Maybe you just miss a package?

OTOH, especially on a server, Wicked might be better suited anyway.
NetworkManager is primarily designed to make a user’s life easier, not so much to run on a server I think.
You cannot even really control it from the command line/text mode. Yes, there’s nmcli, but that cannot create a connection, e.g.

  1. Ensure Wicked is selected in Yast Network Settings
  2. Disable NetworkManager service via terminal commands

If you select Wicked in YaST, NetworkManager should be disabled automatically, and vice-versa.

That’s the reason why I told you to switch to NetworkManager to get the applet to work.
If both would be running, you’re bound for trouble anyway.

Any thoughts?

Thoughts about what exactly?

Uninstalling NetworkManager should not influence Wicked at all.
But it would cause other packages to be uninstalled as well. On my system that would include gdm, gnome-shell, gnome-session and epiphany (and of course the NetworkManager plugins and frontends).
This may not bother you on a server though, or if you use KDE anyway.
But then, just having it installed doesn’t influence Wicked or cause problems either.

Regarding “if it would be better in the long run”, well, I’m quite sure that NetworkManager will not be dropped from the distribution in the foreseeable future or even years…
And wicked is probably bound to stay as well, on (open)SUSE that is.

Was using “yast” to modify or correctly input static IP settings. Not the desktop NetworkManger app. When the networkmanager failed to allow me to setup static ip (yast options grayed out) I changed to Wicked, but it would not open up edit ability to modify or adjust IP address / subnet information.

But as you used NetworkManager in the past, you should know that already, and I thought I made that clear already. Or did I misunderstand you?

Probably just “potato vs. potatoe” on my part… I was pointing to using the Yast network settings tool.

OTOH, especially on a server, Wicked might be better suited anyway…

Agreed…

Uninstalling NetworkManager should not influence Wicked at all. But it would cause other packages to be uninstalled as well. On my system that would include gdm, gnome-shell, gnome-session and epiphany (and of course the NetworkManager plugins and frontends). This may not bother you on a server though, or if you use KDE anyway. But then, just having it installed doesn’t influence Wicked or cause problems either.

I am running KDE, for now so Gnome is not a concern, interesting as Yast Software handler wants to pull in gnome on a KDE box… Was not sure if the two (Wicked and NetworkManager) shared resources, or libraries. Thanks for answering that question for me.

Charles.

But you wrote: “Every time I try and use NetworkManager all options to adjust network settings remain grayed out, no network connections to the outside can be made.”, and “Disabling Wicked and going back to NetworkManager, all settings for configuring NIC are grayed out”.

And now you say you in fact switched to Wicked and everything was greyed out?
This all is really a bit confusing…

But again, just to be clear:when using NetworkManager, YaST will not let you change any options. You’ll have to use a NetworkManager frontend on that case (both KDE and GNOME provide one).
OTOH, when using Wicked (or ifup in earlier releases), those NetworkManager frontends do not work. You can only change the settings with YaST then.

And it started to work for you, when you manually disabled NetworkManager? Then either you didn’t really switch to Wicked, or you somehow had both running. But switching in YaST between the two should disable the other one, unless there’s a bug in YaST

Probably just “potato vs. potatoe” on my part… I was pointing to using the Yast network settings tool.

Ok. So infact not NetworkManager, but ifup.

But this thread was originally about NetworkManager, i.e. KDE’s NetworkManager applet, not working.
No wonder that it’s getting confusing when you append your Wicked (i.e. non-NetworkManager) problem here and even use fuzzy terms like saying “NetworkManager” while actually referring to YaST, I have to say.

I am running KDE, for now so Gnome is not a concern, interesting as Yast Software handler wants to pull in gnome on a KDE box…

Hm? No, YaST does not want to pull in GNOME. YaST will want to uninstall GNOME if you remove NetworkManager.

Was not sure if the two (Wicked and NetworkManager) shared resources, or libraries.

Well, they definitely share some libraries, glibc at the very least… :wink:

But wicked does not use any libraries/resources from NetworkManager, no.

PS, that just came to my mind:
With “Disabling Wicked and going back to NetworkManager, all settings for configuring NIC are grayed out” do you mean, that after disabling Wicked and starting YaST again, the settings were greyed out?
Well, I hope it should be clear why in the meantime.
And if you disable Wicked and not switch to NetworkManager, you disable networking as a whole anyway.

OK… as best as I can explain this situation, writing from my notebook, as I have to take the server down over lunch to test.

I switched back to network manager in Yast, and when selected, and it goes right back to where I cannot update / change adapter properties, IP information or connection details and states is either being controlled by Wicked or not available. Attempting to use NetworkManager App from desktop, says not connected, no devices available.

Return to Yast network settings, change back to Wicked from drop down, and I can immediately edit most of the settings including adapter - just not the IP / Subnet / Hostname information. Go into terminal, disable all NetworkManager services, reboot and go back into Yast, settings are now available, altho I still have to set up static IP information (IP, Routing, DNS) manually, cannot access subnet, as it continues to remains greyed out. This appears to be automatically ajusted if you are on a private LAN address versus public address… Still looking into this.

After I exit Yast, I check the WAN for connections, edit host file to provide FQDN and reboot to save changes. Once restarted, the right host name is present and the server is running normally. It would appear that once I have the Wicked settings correct, the server works as expected. As I am not using Gnome, I will continue on with Wicked vs. NetworkManager.

Thanks for the help, your information is quite on point, even if I was not.