network HP printer

HI I am new to Opensuse. I am using 15.3. Coming from Debian based distributions this is a new curve for me. I do not fully understand the versions of the HPLIP package. I think I may have installed the wrong one cause My Hp 5530 is not being found. I am using 3.21.10 4.3.1 vendor SUSE LLC. I did read this post below but I am not sure which one to use its a bit confusing.

My printer is a Wlan Printer, I install them first connected with USB, after that connected with Wlan without Problems:
As root:


I will try that thanks

After many attempts with hp setup I got it to work after I removed and re-installed hplip. My 1st attempt for some reason the GUI setup would not take my user and password when it asked me to run.

hp-setup ( printer IP address)

The second time run ahead and tried to configure the printer before I enter my passphrase for my network. I feel that I am back in the 1990’s with this. I am evaluating Opensuse as a possible option for older computers. Not that KDE is lower resource. With my Linux mint the printer is auto detected and installed. Think that kind makes users complacent but not for a new user.

What is it with the random question thing? its bugging me.

My HP printer randomly disappears as well. The easiest way to get it back is to manually install to the network. It will have the same ip as before it disappeared. Annoying but not difficult to resolve,

So are you using KDE or Gnome when printer disappears? I never had that issue in Debian based distributions.

I’m using KDE. While I don’t print often anymore, I can’t be sure when I “lose” the printer. However, I think it probably happens when the power goes out in a storm or when I my router loses the wifi settings. That probably is related to power outages as well. In other contexts, people have complained about waking from a low power mode or sleep mode. I have gone weeks without printing and my printer hibernates after all that time!

When I had to use hp setup to got my printer to be installed. In over 5 years I never need to manually install the printer due to Ubuntu and mint have auto detection for a networked printer. I have used hp-setup in years not sure if this is a good thing or not. Cause some brands do not like the auto detect and will not install. In Ubuntu Cups is installed and hplip is a dependence for cups in Ubuntu. which I found odd not all users use HP brands. I think it may be due to IPP driver-less printing.

I’ve been using the technique that I documented in this blog entry for over 10 years on various openSUSE versions (up to and including LEAP-15.3):

The HP network printer has changed since this blog entry, but the same technique still works.

More recently (3 years ago) I used the same technique on a newer printer:

The openSUSE menus have also changed slightly, but again, the same technique works. The hardest part in all this is knowing the IP address of the printer. Fortunately for my HP-All-In-One-2675 both my router and the printer supported WPS.

I been using the HP instant ink service The ink cartridges in the service are larger than the retail. I started it I think in 2019. I pay around 4 bucks bucks a month. This is is the first year I got ink sent to me to replace a low cartridges.

I was buying the ink locally at an office supply store which would be around every three to 4 months of 50.00 for the combo set. I would have to buy both cause most do not sell them separately twice a year. I play 60 total for the service and that saves me at least 50 bucks a year. Though this only works for WiFi models on a network. I never got WPS to work on printers that supported it ever.

WPS hasn’t worked for me either on my HP printer. Another annoyance is that my router didn’t see the printer, so I couldn’t get the ip from the router web page. But, since I had a prior connection on this printer, I used the printer to tell me its ip and that worked to manually connect via hp-setup.

You can get printer IDs with printing service page.

Here’s something I can’t explain. I lost the wireless connection and nothing I did could get it back. The router simply did not see the printer and the printer did not see the network. For other reasons, I booted into Windows and the printer connected automatically, although with a new IP address. When I booted back into TW, the printer remained connected.