Net connection no longer working on XP after OSUSE installed

Hello people :wink:
Good day to all :slight_smile:

I installed Open Suse 11 last week and it is setup to dual boot with Windows XP. Everything works fine on the installation.
And it is great because of ease of installation and user friendliness. I have also tried using OpenSUSE’s Mozilla Firefox in browsing the internet,
But here’s the problem i encountered :frowning:

when I restart and login to windows the internet is no longer working. It always say “Media disconnected” when i run ipconfig.

I tried the ff.

  1. Complete shutting down the computer and starting up again instead of restart.
  2. Turning off my dsl modem and turning it on again.
  3. Reinstallation of my LAN card driver.

but i still dont got luck on that.

Since I cannot make it to work, I search the net and I found this thread:

LAN works in linux but no longer works in windows - openSUSE Forums

The scenario on that thread, the computer is connected on a LAN but on my scenario, my computer is directly connected to the DSL modem.
I tried the solution mentioned in there but still got no luck. I also tried to asked the thread creator but got no reply.

Here’s my spec:

OS: Microsoft Windows XP Professional SP2
CPU: Intel(R) Core™2 Duo CPU E6550 @ 2.33GHz
MEMORY: 2048MB RAM
LAN: Atheros L2 Fast Ethernet 10/100 Base-T Controller (Built in on board)
DSL MODEM: ZyXEL P-600 Series

Any suggestion and help are appreciated. Thank you very much :slight_smile:

I have never had any such experience before. I read the thread you quoted but it doesn’t seem to offer anything useful. If it were me I would get my hands on a PCI eth device if you have a spare slot (assuming you are on a box).
But I’m not sure how Linux or Windows for that matter, can have any control over a device once it has been shutdown.

Just see if you have any settings in the BIOS to disable the Ethernet port.

The scenario on that thread, the computer is connected on a LAN but on my scenario, my computer is directly connected to the DSL modem.

… which does not make any difference in this case as it seems to be same network card.

syampillai adjusted his/her AFDB on Sunday 31 May 2009 07:36 to write:

>
> Just see if you have any settings in the BIOS to disable the Ethernet
> port.
>
>

Also try and enable WOL and or Boot ROM in your BIOS.

I have seen similar probs but normally the other way round where a Win
driver will disable the LAN until the machine boots back into windows.

This was with older realtek cards I think though but it should not hurt,
enabling WOL and/or the Boot ROM should enable the card on reboot no matter
what state the driver left it.

HTH

Mark

Nullus in verba
Nil illegitimi carborundum

Hi baskitcaise, :slight_smile:
Thank you for the reply.
I tried your solution but still i’m not lucky on solving the solution on our problem.
I try to enable LAN Option ROM in BIOS.
Is that the one your mentioning? Sorry, but it doesn’t work.

I check other settings related to settings in BIOS like Power On By External Modems and Power On By PCI Device but still, i’m not lucky.

Thanks,

Found this thread it isn’t just power down really leave it off for a bit if you haven’t. The other bits may help but I’m going for a proper power down notice they discharged, what they called whatever static remained.

Linux broke my NIC! Seriously. (cable unplugged issue) - Tech Support Forum

I also stumbled across this as well. Though they think it was related to playing with power I suspect it was just allowing the card to reset similar to the above.

vista lost connection permenenatly

I had the exact same problem, I was able to remedy this by opening device manager and uninstalling the network card; which in my case is an Intel 82567LF-2 Gigabit, either restart your computer selecting windows operating system or from the control panel select add new hardware. Your system will find the card you just deleted and reinstall the drivers for it. Hope this works for you like it did for me.

Ok I’ll try it up, but do i need to do that everytime i boot to Windows after I used SUSE?:’(