I installed a software on opensuse 11.2 64 bit, but when i run it i have an error message: “error while loading shared libraries: cannot open shared object file: No such file or directory” . Where can I find this library? I tried through Yast but this library is not present

Install xorg-x11-libs. You could have found this with yast searching for libXft and enabling the option RPM ‘provides’.

xorg-x11-libs is already installed, but it provides only Maybe I can link the execution of so.1 to so.2, but I don’t know how to do this. Where can I find so.1 and how can I install it? thanks in advance.

I solved my problem: I simply copied from /usr/lib64 to the program’s directory and renamed it as Now the program works, it doesn’t seem to have problems or other issues. in that case I will ask your help again, but for now thank you for your support

Having a closer look I found that 11.1 provides the following in directory /usr/lib:

ls -l /usr/lib/libXft*
lrwxrwxrwx 1 root root    16  9. Jan 2009 ->
lrwxrwxrwx 1 root root    13  9. Jan 2009 ->
-rwxr-xr-x 1 root root 59596  9. Dez 2008
lrwxrwxrwx 1 root root    16  9. Jan 2009 ->
-rwxr-xr-x 1 root root 84176  9. Dez 2008

In 11.2 they dropped and the links. You may add them manually and then run ldconfig as user root. Then you don’t have to copy and rename the library. Please tell us if this works.

I have the same problem. This is what I got:

linux-titj:/usr/lib # ls -l libXft*
lrwxrwxrwx 1 root root    16 2009-12-25 19:01 ->
lrwxrwxrwx 1 root root    16 2009-12-22 20:28 ->
-rwxr-xr-x 1 root root 84176 2009-10-19 13:21

I don’t have the in 11.2, so how do I link the so.1 to the so.2? Thanks in advance.

ln -s what where
or use mc menu…