Need help with codecs installation

Hi all.
First, I did read the stickies, and finding several installation methods for multimedia codecs got me a bit confused. I’m using openSUSE 12.1 x86_64.

First there’s the one-click way: Restricted formats/12.1 - openSUSE Community Wiki.
There’s Caf4926’s method. (By the way, he’s really good at writing tutorials).
And there’s the on-demand method, which is letting Kaffeine download and install the necessary codecs (provided one have at least Packman repository functional).

Maybe my first doubt is, do the first 2 ways work on 64-bit systems? For example w32 codecs are NOT for 64-bit systems. Already tried that before and even looked for a “w64” package…

Other doubt is, does one-click method still works, or “adapts” to 64-bit systems? I guess it installs less codecs than Caf4926’s method. But again, the w32 question…

Is Flash Player for Youtube videos included, or should I better install it directly from Adobe?

Finally, how good would Kaffeine’s on-demand method be?

Yes, I’m probably messing up myself, and I apologize for too many questions. It’s just that I don’t know how many of the installed stuff will I really use (Caf’s method), though I want to be able to play the most formats possible. For example, this user was still missing some codecs in order to correctly play all his files.
I’m also not used to zypper yet, though it’s a more direct way to install from console than Yast. I use to mistake it with yum…

I’m also kind of nervous. It’s the first time I try to install an entire new Linux system by myself alone, and it seems I’m not too autodidact. Again, apologies, and thanks for your help.

Just follow my guide

w32codecs are virtually obsolete
Leave it out if you like

The One click will work too, but it will leave you lacking codecs for some playback

Flashplayer is in my guides code
But it will get pulled in automatically anyway as you update.

So where would you recommend to install Flash Player from? From Adobe website or the repository way?

Like I said
Flash will be pulled in automatically from the repos, which is fine.

OK, followed your guide, installed most of the stuff except additional players, w32-codecs, dvd stuff (libdvscss2, libdvdplay0, libdvdread4, libdvdnav4) because I think I won’t need it for now, so I didn’t add libdvdcss repo.
lsb and xine-ui were nowhere to be found in Packman.

Did I do well? Also, there were 2 versions of libavcodec. libavcodec53 was installed by default, so I installed libavcodec52. Don’t they conflict each other?
Thanks for help.

That sounds fine
libavcodec52 and 53 are fine

lsb and xine-ui are there

Let me see

rpm -qa lsb xine-ui
zypper lr -d

Can you play videos here
iTunes Movie Trailers

From zypper lr -d:

| Alias | Nombre | Activado | Actualizar | Prioridad | Tipo | URI | Servicio

1 | Actualizaciones-para-openSUSE-12.1-12.1-1.4 | Actualizaciones para openSUSE 12.1 12.1-1.4 | Si | Si | 99 | rpm-md | Index of /update/12.1 |
2 | Nvidia | Nvidia | Si | Si | 99 | rpm-md | |
3 | Packman | Packman | Si | Si | 99 | rpm-md | Index of /suse/openSUSE_12.1/ |
4 | | Mozilla | Si | Si | 99 | rpm-md | Index of /repositories/mozilla/openSUSE_12.1 |
5 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Si | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVD+_-RW_TS-L632D,/dev/sr0 |
6 | repo-debug | openSUSE-12.1-Debug | No | Si | 99 | NONE | Index of /debug/distribution/12.1/repo/oss |
7 | repo-debug-update | openSUSE-12.1-Update-Debug | No | Si | 99 | NONE | Index of /debug/update/12.1 |
8 | repo-non-oss | openSUSE-12.1-Non-Oss | Si | Si | 99 | yast2 | Index of /distribution/12.1/repo/non-oss |
9 | repo-oss | openSUSE-12.1-Oss | Si | Si | 99 | yast2 | Index of /distribution/12.1/repo/oss |
10 | repo-source | openSUSE-12.1-Source | No | Si | 99 | NONE | Index of /source/distribution/12.1/repo/oss |

From rpm -qa lsb xine-ui: no output at all, back to command waiting.

Tried this one, for example, if this is what you mean: Fullmetal Alchemist: The Sacred Star of Milos - Movie Trailers - iTunes
I have never visited that website before, so I don’t know how exactly it works. But when clicking “Watch now” a window opens just with a Quicktime symbol, and if I click it redirects me to Quicktime download. And I’m sure I have libquicktime0 installed.

Run the multimedia again and don’t miss stuff out

“Run multimedia”? I used Yast to individually install the stuff, not one-click or other method. Do you think the stuff I skiped (including media players) is preventing from playing Quicktime online? What about xine-ui and lsb, where are they?

Also, are there codecs to be able to play .rm or .rmvb movies, or do I really need another player?

Use the code for the kde install from here

Yes, mplayer stuff is important. That is why I wrote the guide. If you don’t follow it…!

So please run the code in a su terminal
And it’ll just skip over stuff you already have

xine-ui and lsb are in OSS

Thanks, mr. Caf, you were right. Did it complete this time (only skipping w32-codecs as you said it was obsolete and they are for 32-bit systems), and I can watch movies on iTunes Movie Trailers. I’m also able to play several video formats on Kaffeine, for now… except rmvb. When I try to play a rmvb file Kaffeine dispalys a “ error”. What do I need to play rmvb or rm movies?

Also, I always used to use “su” instead of “su -” to log in as root, though this time I used the second one to install. What’s the difference between the two?

I use smplayer for rmvb

try it

and look at your terminal address

now try su -
and look at the address

There was a discussion that educated me in more detail

Thank you, mr. Caf. Finally, what’s the difference between zypper and yum? At the beginning I was tempted to use yum…

yum? Is used in a different distro (Fedora)
Maybe you mean something else?

Maybe I was a bit confused since RedHat, CentOS, Fedora, openSUSE itself, are RPM-based distros. I have also tried a little bit CentOS and it uses yum IIRC.
Very thank you for all your help, you’re one of the best reliable help sources, and sorry for being a bit annoying. (I left message on Applications…).

You are most welcome
There is a zypper guide here
SDB:Zypper usage 11.3 - openSUSE

Or type this in konqueror address bar