Need Help Setting Up Remote Administration

Ok. To start I must say this has been driving me mad.

My issue is that I can’t seem to get Remote Administration (vnc) working for the life of me. I tried the ip4/ip6 fix and every other work around I could find. I simply can’t figure things out. I can’t say I’m new to Linux but I can say that I am quite new to openSuse and the RPM world in general.

My actual error isn’t much of an error but that of the vnc window just being a black window that eventually times out.

As of now I access and configure the box vis ssh.

I’m using:
openSuse 11.3
Gnome Desktop
Installed from gnome live CD

Your advice would be much appreciated. As someone moving from the Debian world the new environment is a bit confusing.

Which vnc RPMs are you using and how are you starting the server?

What I did was enable Remote Administration in yast then do a system update.

Whatever the defaults yast sets up are, are what I have.

Vnc when enabled that way, it uses the xinetd method for serving the remote desktop. The IPv6 adjustments you read about in these forums are aimed at that method. And it seems the IPv6 workaround is again problematic (in openSUSE 11.3).

If you can’t get it working, you could try the other method, which uses the command “dbus-launch vncserver” rather than xinetd to start the vnc server. It has worked reliably for vnc in openSUSE throughout the three year ordeal we’ve had with vnc in openSUSE.

Personally I think the xinetd method is superior. The only thing wrong with it is that it doesn’t work in 11.3 (yet).

You can view the “dbus-launch vncserver” method here: TightVNC (VNC Xvnc) on openSUSE as Client or Server (Remote Desktop Connections)

Just an afterthought: I’ve just finished checking xrdp and whether it works in openSUSE 11.3, it turns out that it works very well. You might prefer to use xrdp which is quite simple to use when compared to VNC in openSUSE. My notes on xrdp are here: Windows Linux RDP Remote Desktop Connections using openSUSE as Client or Server (terminal server)

Thanks alot! I used the RDP method and it works wonders. It kind of funny though. I am using Microsoft’s RDP client on a Mac to connect to a Linux box. Ha!