Need help in solving grub2 boot menu video resolution

Hi,
I connected the desktop pc with tumbleweed on a 65" 4k samsung tv, the video resolution is fine,
meaning it worked nicely after I login to xfce with the resolution of 3840x2160.

My problem is the grub boot menu that default always to 1024x768
that make the tumbleweed logo’s shape becomes oblong rather than a perfect circle.
The videoinfo is only limited to 3 options like so:

800x600x32
1024x768x32
1280x1024x32

Framebuffer info:

# hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.KwpZt39d_L2
  Hardware Class: framebuffer
  Model: "NVIDIA GK106 Board - 20100015"
  Vendor: "NVIDIA Corporation"
  Device: "GK106 Board - 20100015"
  SubVendor: "NVIDIA"
  SubDevice: 
  Revision: "Chip Rev"
  Memory Size: 14 MB
  Memory Range: 0x01000000-0x01dfffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0330: 320x200 (+320), 8 bits
  Mode 0x0331: 320x400 (+320), 8 bits
  Mode 0x0332: 320x400 (+640), 16 bits
  Mode 0x0333: 320x400 (+1280), 24 bits
  Mode 0x0334: 320x240 (+320), 8 bits
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Mode 0x0345: 1600x1200 (+1600), 8 bits
  Mode 0x0346: 1600x1200 (+3200), 16 bits
  Mode 0x034a: 1600x1200 (+6400), 24 bits
  Mode 0x034b: 1280x1024 (+1280), 8 bits
  Mode 0x034c: 1280x1024 (+2560), 16 bits
  Mode 0x034d: 1280x1024 (+5120), 24 bits
  Mode 0x0360: 1280x800 (+1280), 8 bits
  Mode 0x0361: 1280x800 (+5120), 24 bits
  Config Status: cfg=no, avail=yes, need=no, active=unknown

Is there a way to correct that said boot resolution problem.
Is there a way to trick the grub2 to recognize a higher resolution like 1920x1080 at least
even though that resolution is not listed?

This desktop pc is using the latest tumbleweed snapshot with xfce
The graphics card is an old nvidia geforce gtx 650 ti and using
the hardway driver.

Many thanks in advance.

I am not sure it helps, but once I had a system that di dnotuse the correct screen resolution with GRUB.
I used YaST > System > Boot Loader. The tab Kernelparameters. There there is an item Graphical concole, which is checked and the resolution is below it. The resolution I need was not in the pull down list, but I could enter what I need in the field.

It worked.

Here is a nice tutorial.
https://www.dedoimedo.com/computers/grub-hd-scaling-resolution.html

All of my machines listed below are configured with “yast2 bootloader > Kernel Parameters > Graphical console > Console resolution > Autodetect by grub2”.

On two most common platforms - PC BIOS and UEFI - grub is using firmware services for video output, so it can only select video mode offered by the firmware.

hcvv I am not sure it helps, but once I had a system that di dnotuse the correct screen resolution with GRUB.
I used YaST > System > Boot Loader. The tab Kernelparameters. There there is an item Graphical concole, which is checked and the resolution is below it. The resolution I need was not in the pull down list, but I could enter what I need in the field.

It worked.

karlmistelberger
All of my machines listed below are configured with “yast2 bootloader > Kernel Parameters > Graphical console > Console resolution > Autodetect by grub2”.

Thanks, that’s what I do every time even way way back when I started using opensuse.

hui Here is a nice tutorial.
https://www.dedoimedo.com/computers/…esolution.html

Thanks for the link

arvidjaar
On two most common platforms - PC BIOS and UEFI - grub is using firmware services for video output, so it can only select video mode offered by the firmware.

Thanks, I dig somewhere a bit and yes I have to leave with what I have right now, anyway it’s only for a second that the menu will show up.

It’s a shame for this monitor, my other two monitors with tumbleweed it has a 1920x1080 and works great.

Thanks to all for your replies.

If “auto” doesn’t work properly input the desired value. See e.g. Setting the resolution or character size for boot and text consoles on SLE 12 and newer | Support | SUSE

Hi,
Thanks. I already did those things even manually doing the changes in/etc/default/grub before I started this thread.
I also did a custom edid in the /usr/lib/firmware to load for the KMS and I saw it loaded after.

Here is the part of the lsinitrd

drwxr-xr-x   2 root     root            0 Aug 15 11:56 usr/lib/firmware/edid
-rw-r--r--   1 root     root          256 Aug 13 16:46 usr/lib/firmware/edid/edid.bin
drwxr-xr-x  18 root     root            0 Aug 15 11:56 usr/lib/firmware/nvidia
drwxr-xr-x   4 root     root            0 Aug 15 11:56 usr/lib/firmware/nvidia/gm200
drwxr-xr-x   2 root     root            0 Aug 15 11:56 usr/lib/firmware/nvidia/gm200/acr
-rw-r--r--   1 root     root          340 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/acr/bl.bin.xz
-rw-r--r--   1 root     root         4836 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/acr/ucode_load.bin.xz
-rw-r--r--   1 root     root          548 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/acr/ucode_unload.bin.xz
drwxr-xr-x   2 root     root            0 Aug 15 11:56 usr/lib/firmware/nvidia/gm200/gr
-rw-r--r--   1 root     root          252 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/gr/fecs_bl.bin.xz
-rw-r--r--   1 root     root          508 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/gr/fecs_data.bin.xz
-rw-r--r--   1 root     root         8340 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/gr/fecs_inst.bin.xz
-rw-r--r--   1 root     root          128 Aug  9 09:35 usr/lib/firmware/nvidia/gm200/gr/fecs_sig.bin.xz

There’s a work around in this old thread,
https://forums.opensuse.org/showthread.php/539590-plymouth-splash-screen-shows-vendor-logo-at-incorrect-aspect-ratio-(EFI-boot)
but the problem is, my desktop advance bios option is lock and there’s no way to do the solution in that thread.

What vendor and model of main board?

**erlangen:~ #** inxi -zM 
**Machine:**
  **Type:** Desktop **Mobo:** ASUSTeK **model:** PRIME B450-PLUS **v:** Rev X.0x 
    **serial:** <filter> **UEFI:** American Megatrends **v:** 2409 **date:** 12/02/2020 
**erlangen:~ #**
Machine:
  Type: Desktop System: Hewlett-Packard product: h8-1213c v: 1.00
  Mobo: PEGATRON model: 2AD5 v: 1.03 serial: UEFI: AMI
    v: 8.21 date: 10/20/2014

12 years old pc.