Nautilus - PDF file "Open With" doesn't find pdfshuffler

Leap 42.3/Gnome:
pdfshuffler is installed on my system from the standard openSUSE-Leap-42.3-Oss repo.
It works fine when the script somewhat cumbersome is started first and then add the wanted pdf file to it.

But using Nautilus, pdfshuffler isn’t found among the available applications on right-click pdf “Open with” menu (like i.e Evince).
I wonder why it isn’t integrated this way default, and next what is the easiest way (gui) to fix it?


Hmmm, didn’t realize it had been pushed to 42.3…

OK, a couple of options, edit the desktop file and add %f (as root user);

vi /usr/share/applications/pdfshuffler.desktop
exec=pdfshuffler %f

If that doesn’t work, then another method is install perl-File-MimeInfo and perl-File-DesktopEntry and change to a directory with a pdf and run;

 mimeopen -d <some>.pdf 

Please choose a default application for files of type application/pdf

    1) LibreOffice Draw  (draw)
    2) Document Viewer  (evince)
    3) GIMP  (gimp)
    4) Other...

use application #4
use command: pdfshuffler
Opening "<some>.pdf" with pdfshuffler  (application/pdf)

Quit and now if you open Nautilus and right-click on a pdf, pdfshuffler will be the default.

Thank you, the first option worked.
I found pdfshuffler first time after that among <View all application>, selected it, and next time it was remembered as the last used app on top of the list. Next, started Evince from “open with”, and lastly after that found pdfshuffler also with “open with” (if that was interpreteable).