Narrow preview pane in Evolution

My Evolution preview pane is now so narrow that I cannot read any emails. Does anyone know how to change that?

Evolution 3.42.4
Groupware Suite
Gnome Version 41.8

It is a know bug which is worked on…
https://bugzilla.opensuse.org/show_bug.cgi?id=1213858
https://bugzilla.opensuse.org/show_bug.cgi?id=1214878

1 Like

Aah…good to know…

And what could I do in the meantime, as I urgently need to read my mails? Anything, even if primitive…

Did you read the bug reports there appears to be a work around there

1 Like

I did. But I didn’t understand them. In particular 1214878 seems to have a recommendation to follow, but for Leap 15.4.

This one:
https://forums.opensuse.org/t/leap-15-5-evolution-evo-file-10-referenceerror-can-t-find-variable-evoeditor-after-update/168797/9

1 Like

I do not understand what that is about. I have those packages at 4.45.3 apparently.

But where does the patch come from? I understand the term ‘locked’ to mean packages that are earmarked not to be updated.

And how do I revert to the packages 4.42.4?

Example:

zypper se -s libjavascriptcoregtk-4_0-18
Loading repository data…
Reading installed packages…

S | Name | Type | Version | Arch | Repository
—±----------------------------------±--------±---------------------±-------±------------------------------------------------------------
vl | libjavascriptcoregtk-4_0-18 | package | 2.40.5-150400.4.45.3 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
il | libjavascriptcoregtk-4_0-18 | package | 2.38.6-150400.4.42.4 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
vl | libjavascriptcoregtk-4_0-18 | package | 2.38.6-150400.4.39.1 | x86_64 | Main Repository

I marked bold the Version, what you mean is the Release.

Goto Yast—Software Installation, search for the package, mark the package and go to the Version Tab and mark the Version 2.38.6

Auswahl_207

1 Like

Many thanks. :+1: All works again correctly. :joy:

If I should lock those 8 packages, how will I know when to unlock them? What is the signal that the correction patch has been implemented?

I Think, It will been reported here.

1 Like

Patch is there, you can update.

1 Like

Patch is where? I have only noticed references to Leap 15.4.

Or do you mean that there is no need to lock the files because any updates will now contain the patch?

Here on Leap 15.5:

zypper if -t patch openSUSE-SLE-15.5-2023-3556
Loading repository data...
Reading installed packages...


Information for patch openSUSE-SLE-15.5-2023-3556:
--------------------------------------------------
Repository  : Update repository with updates from SUSE Linux Enterprise 15
Name        : openSUSE-SLE-15.5-2023-3556
Version     : 1
Arch        : noarch
Vendor      : maint-coord@suse.de
Status      : applied
Category    : security
Severity    : important
Created On  : Fr 08 Sep 2023 14:39:54 CEST
Interactive : ---
Summary     : Security update for webkit2gtk3
Description : 
    This update for webkit2gtk3 fixes the following issues:

    - Provide/obsolete WebKit2GTK-%{_apiver}-lang (bsc#1214093)
    - Have the lang package provide libwebkit2gtk3-lang (bsc#1214093)

    - Adjustments of update version 2.40.5 (bsc#1213905 bsc#1213379 bsc#1213581):
      + Added missing CVE references: CVE-2023-32393, CVE-2023-37450
Provides    : patch:openSUSE-SLE-15.5-2023-3556 = 1
Conflicts   : [160]
    WebKitGTK-4.0-lang < 2.40.5-150400.4.48.1
    WebKitGTK-4.1-lang < 2.40.5-150400.4.48.1
.
.
.
.
.

zypper se -si webkit2
Loading repository data...
Reading installed packages...

S  | Name                            | Type    | Version              | Arch   | Repository
---+---------------------------------+---------+----------------------+--------+-------------------------------------------------------------
i+ | libwebkit2gtk-4_0-37            | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | libwebkit2gtk-4_1-0             | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | libwebkit2gtk-5_0-0             | package | 2.38.6-150400.4.42.4 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | typelib-1_0-WebKit2-4_0         | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | typelib-1_0-WebKit2-4_1         | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | typelib-1_0-WebKit2-5_0         | package | 2.38.6-150400.4.42.4 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | webkit2gtk-4_0-injected-bundles | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | webkit2gtk-4_1-injected-bundles | package | 2.40.5-150400.4.48.1 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
i+ | WebKit2GTK-5.0-lang             | package | 2.38.6-150400.4.42.4 | noarch | Update repository with updates from SUSE Linux Enterprise 15
i+ | webkit2gtk-5_0-injected-bundles | package | 2.38.6-150400.4.42.4 | x86_64 | Update repository with updates from SUSE Linux Enterprise 15

1 Like

Use
zypper up

Hi all,
i upgraded today to leap15.5 and am facing exact the same problem.
I did patch as advised here. Zypper se -si webkit2 shows exact the same result as Sauerland posted.
But this solves not my problem. Mails are still unreadable because the mailbody pane is a oneliner.
Can anyone help me in this?

Greetings,
Nala

@Nala
https://forums.opensuse.org/t/leap-15-5-evolution-evo-file-10-referenceerror-can-t-find-variable-evoeditor-after-update/168797/17

Hi Sauerland,

as i have understood this is not a bug in Evo but a bug in libwebkit2gtk packages.
I have a 2nd server running with Leap15.4.
Both the 15.4 and my new 15.5 Server have exact the same evolution version but the libwebkit2gtk packages are different.
On the 15.4 Server it is libwebkit2gtk-4_1-0-2.38.6-150400.4.42.4.x86_64 while it is libwebkit2gtk-4_1-0-2.40.5-150400.4.48.1.x86_64 on the 15.5 server.

Greetings,
Nala

It helped another person here in the forum to (run as root in konsole(terminal):

zypper install --oldpackage ./evolution-3.42.4-lp154.4.1.x86_64.rpm

Not ideal solution but for the time been…
Regards

Hi all,

downloaded now evo and the libgtk2 files from https://download.opensuse.org/repositories/GNOME:/STABLE:/41/openSUSE_Leap_15.4/x86_64/ and downgraded evo and the libs and added them to lock.
Now i can see again my mailbody.
Not the ideal solution, but as workaround sufficient … until the bug is fixed.

Greetings,
Nala

Hi all
There is a new update for webkit2gtk3 in 15.4 (3753-1) …
The preview panel remains narrowed :slightly_frowning_face:
Back to old libs.