MySQL phpMyAdmin problem

Hi folks!
I’ve installed MySQL database from OpenSUSE page (it is Maria version) and now I have problem.
I can access to base via terminal, but when I want to communicate with base via browser it responds with error:

#1045 Cannot log in to the MySQL server

Where I made a mistake during installation and how to fix that?
Thanks a lot and happy New Year!

MySQL error 1045 is a user authentication error (it is NOT a connection error. It is the MySQL server that returns an error so you are actually connected to MySQL. But the server disconnects you again, as your credentials cannot be approved). The original MySQL error message reads “Error No. 1045: Connection denied for ‘someuser@somehost’ using password: YES|NO” - but PMA seems to rewrite it.

Probably PMA tries to connect as a (MySQL) user, that has not been created in MySQL. PMA has some configuration file where you define this. I don’t remember the file name, but it is easy to identify.

In MySQL commandline execute “SELECT user, host FROM mysql.user;” to see what users exist. Create a user to be used by PMA and GRANT what privileges the user should have. Alternatively edit PMA config to use an existing user (root if you want, but it is not recommened to connect as root from PMA on a production environment).

Relevant MySQL documentation links:
http://dev.mysql.com/doc/refman/5.5/en/privilege-system.html
http://dev.mysql.com/doc/refman/5.5/en/grant.html

You have to enable and start mysql from Yast - System - Services
Next you’ll have to create a mysql root user password, plus (better) create a mysql user to access the databases through phpMyAdmin

Thanks folks!
Now I can use phpMyAdmin.