My wifi does not work anymore!

Hello, I explain my little story:

I have installed opensuse Tumbleweed about 1 year ago. During the installation, I had to configure the wifi on my HP laptop 15-ba022nf. In fact the internal card of the computer only captures 2 wifi networks with a very bad signal even if I am close to the router.

So I used the commands:

modprobe -r -v rtl8723be
modprobe rtl8723be ant_sel=0 -v

And everything started to work properly!

But recently (about a month ago) I updated my computer, and now it seems to be back to the starting point:

No matter if I select antenna 0 or 1 (I even tried other crazy values ​​like 2 and 3) I never have more than 2 available wifi networks with a very weak signal and a non-existent bit rate.

It seems that the command to select the right antenna does not work. (on my computer the wifi card is at the same time a bluetooth card, and it has 2 antennas, for each type of network) And it seems that the kernels tries to capture wifi networks with the bluetooth antenna…

What should I do to see where the problem comes from and then try to fix it?

Actually 0 should be “whatever hardware is set to use” and valid values are 1 and anything else, e.g. 2.

Anyway, does it work when you boot previous kernel? Or another live distro? It could be simply hardware issue, it is not uncommon for an antenna to fall off …

I have tried my wifi card under windows It works ! I think It is a update problem…

With a little research,
Verified you identified your WiFi hardware correctly.

If the following is not you posting in another forum, he’s complaining about the same thing except his solution which no longer works is to specify ant=1

The thread says that the problem is known, and a fix had been submitted to the mainline kernel(through Ubuntu). That was 3 months ago, and you’d have to research what happened to the supposed fix.

In the meantime, it looks like the current workaround should be to boot to your previous kernel.