My system goes straight to grub rescue

I’m using 12.3 64-bit with the 3.9 kernel. I was using it this morning with no problems. I did no updates or configuration changes. In the evening, I tried to boot up and after a pause at “Welcome to grub”, it went to grub rescue. The message was it couldn’t boot the UUID it was looking for because it wasn’t found. This UUID doesn’t exist on my system.

I created a SuperGrub2 usb stick and was able to boot from that, but if I don’t use it, my system goes back to the same problem. I don’t see where /boot/grub2/grub.cfg was changed in any way.

Does anyone know how I can fix this?

The simplest way to fix it is to reinstall bootloader, using e.g. “update-bootloader --refresh” after you have booted openSUSE.

I tried the update-bootloader command but nothing changed. Any other ideas?

Please run this script after booting into openSUSE and post results to SUSE Paste

Looks like you installed the bootloader on the USB stick. Run Yast - System - Bootloader - Bootloader options and check whether GRUB2 is installed on the internal HDD.
If not, report here what the values are you’re seeing ( screenshot ? )

I made a Super Grub2 utility disc to boot from after my computer wouldn’t boot normally. Grub2 is installed on the root partition on my system.

SUSE Paste says the output of your script exceeds the "max_allowed_packet bytes. Also, I used rescue mode from the dvd and reinstalled grub2 but that didn’t help.

Solved. I checked some of the settings in my BIOS and discovered that a second HDD with no bootable OS was listed as the first drive to boot from. I changed this setting and now my computer is booting normally again. I have no idea how this setting was changed in the first place. I haven’t been into my BIOS in months.