My password doesn't work.... First time installing.

This is my first time installing OpenSuse Tumbleweed. Everything generally went ok but the first time it booted it just auto logged in. It did not ask me if I wanted to login. Then when I tried to connect to the internet it wanted to make some wallet which I fumbled with then it connected. When I tried to do any sudo commands it wouldn’t work. If I logged out I couldn’t log back in. The only way was to reboot and let it auto login.

Not sure what I did wrong. During the install it asked what my user name would be and I entered a matching password… and here I am now.

Any help would be greatly appreciated.

ps. this is dual booted with windows10 which is working fine.

The first thing that comes to mind is that the keyboard is not set according to your language, or you have the caps lock, and the pass … is not typed correctly, check.
However it can change.
At the grub press the letter e > in the Kernel line at the bottom after quiet spash> write> init = / bin / bash> and start like this> you are in front of the root shell> type> passwd> reset the pass and reboot

Hello and welcome here.

You seem to have different problems.

First the autlogin. That is something you are asked for to en/disable it in one of the installation screens. I assume that it works now according to the choice you made there.

Then, please tell us more details about your user configuration at installation. You did choose to create a “normal” user and gave it a password (that is what I understand from your description. Did you also check to use the same password for the root user 9which is the default, how terrible that might sound), or did you go for a different password for root?

Then you say “When I tried to do any sudo commands it wouldn’t work”. Now that is only a variant on the infamous “it does not work”. Please show us what happens when you type that sudo command. Inclusing everything: the line with the prompt and th ecommand, all that follows up to and including the line with the next prompt. And please copy/past that from the terminal window between CODE tags in your post here. You ge the CODE tghas by clicking on the button with the # in tool bar of the post editor. The result will then be something like:

henk@boven:~> sudo ls -ld /bin
root's password:
drwxr-xr-x 2 root root 4096 12 nov  2016 /bin

Of course you tried a different command after the sudo, but the command I show above is not only an example, but also a nice way of testing how sudo functions in your system.

Always remind that posting yuor conclusions (like “sudo does not work” or “If I logged out I couldn’t log back in.”) require either showing the computer facts were you base your conclusion on (easy in a CLI situation like the sudo case above), or give a more detailed description on what you do and see for the GUI case (posting screenshots may also a great help when the GUI is involved).

I apologize for the initial post. I kinda barfed it all out late last night before going to bed way too late.

I’m going to re install OpenSuse this weekend and carefully make sure I don’t miss any prompts regarding login behaviour and passwords.

I’ll get back to y’all with the results.

Oh, and take notes about what choices you make during installation.
Next installation you will be glad with them.
And when having problems those notes can also be of value.

Don’t bother. We’re all people that have never done this the same way :smiley: . Well, I did :smiley:
There’s a couple of things to be aware of:

  • It does make sense to actually read the installer screens, taking some time for the install pays back

  • Linux is case-sensitive, so Wren, WRen, WREn are different things than wren.

  • If you have a spare machine nearby, it can come in handy during install. You can put screen shots on and post the resulting links here if needed.

  • Another option is to f.e. download the KDE Live image , create a DVD or USB stick from it, and install from there. That would make asking questions here during install even easier, since you can make screen shots by hitting PrtScn, and you can copy output of commands from a terminal window to a post here.

  • Please use CODE tags when you post output here, it’s the # in the editor. Makes stuff more readable.

  • And most importantly: have fun !!!

So you did not try as I suggested, or maybe I did not explain how to do it?
Good work with the new installation, and welcome to openSuse

When describing how to preform actions using an interactive shell, it might be better to copy-paste the steps in code tags. You mentioned restting the root password, but omitted discovering and resetting the default user password.

 # *passwd*
New password: 
Retype new password: 
passwd: password updated successfully
 # *grep 1000 /etc/passwd*
cj:x:1000:100:Charlie Joy:/home/cj:/bin/bash
y3:~ # *passwd cj*
New password: 
Retype new password: 
passwd: password updated successfully

I put the steps in series using >>>, maybe it was better to use the code for the commands, I do my best using the translator:P

Hi all re-installing fixed all that. I must have done something extra derpppy while installing late at night.

Thanks for the help!

Glad you have it all working. Enjoy.:wink: