My OpenSUSE problems..


I have a nw8240 from Hewlard Packard. I installed OpenSUSE 11.0 on it, and ofcourse it looks beautiful. However, there are some Software/hardware components that still dont work. What doesnt work:

  • Playing XViD in mplayer, its flickering (installed codecs from opensuse)
  • My integrated bluetooth device (it just doesnt see my device).
  • My Wireless Card 2200BG from Intel (the LED keeps turning on and off)

I tried to ask it on the irc channel and i searched for a solution on google. But the solutions didnt came up and there arent always people on the irc channel. So i thought, lets try the forums! Hopefully you can help me out, because im sick and tired of Windows XP.

I have one more question:
How do i make a file share on startup?

Thanks in advance!


My laptop does not have bluetooth, and I have never tried to set it up. Still, I am in the market for a new laptop (planned purchase Nov-2008) and so I am curious to read about the experienced of other laptop users with openSUSE.

Note this page on bluetooth:
Bluetooth - openSUSE

I also note a Ubuntu user claims to have bluetooth functioning on this model laptop:
Ubuntu GNU/Linux on the HP Compaq nw8240
… noting they used hci_usb.

When you state your openSUSE-11.0 just doesn’t see it, did you type:
to see if it is detected? Note “lsusb” comes with “usbutils”.

If it is PCI based then “su -c lspci” is another way to try detect it.

And if it is not detected, did you try (IMMEDIATELY AFTER a new rebooting) typing:
dmesg > dmesg.txt
and opening up dmesg.txt with a text editor to see if there are any bluetooth related errors. Note dmesg.txt will be very large, please do NOT post it here.

Is fullscreen flash video flickering too?

Try using the install software feature in yast2, Search for bluetooth and install anything you think might suit your needs from the results.
You can find out what each package can do by reading it’s description.

Does the wireless card work?

I had the wireless working fine on my HP6325us lappie by using ndiswrapper on 10.2/10.3. It used to be you had to download and install manually, but then I found on 10.3 ndiswrapper had been integrated into the YaST package management (packman?). I still had to get the driver from my XP installation, but that was available from some folks here or else on my hard drive (I dual boot XP and, mostly, 11.0). I haven’t gotten it working yet on 11.0, but the ndiswrapper utility is still in YaST, so I’m guessing it’s going to be easy once I get around to it.