Mutter with wayland how to?

How can I run mutter with wayland support?:slight_smile:
I am not using gnome, just trying if I can do it in xfce.:
Thanks in advance.

Surprise …

mutter --wayland

Thanks, I’ve been searching about this and never found this command. Could be I am searching the wrong way.
So I tried mutter --wayland and mutter --wayland --replace and turns the same error in the terminal.
The first output from the terminal just vanished and I can’t catch it. I can only get the last one which is this.

(mutter:5496): libmutter-WARNING **: 10:52:41.629: Failed to post KMS update: drmModeAtomicCommit: Invalid argument

(mutter:5496): libmutter-WARNING **: 10:52:41.629: Page flip discarded: drmModeAtomicCommit: Invalid argument

While the terminal is still open with the mutter --wayland, I can’t open the xfce4-settings-manager using the launcher. Here is the error when running it in the terminal.

~> xfce4-settings-manager

(xfce4-settings-manager:8159): libxfce4ui-WARNING **: 10:56:16.834: startup notification not supported for wayland sessions

Does this mean Xfce now in wayland territory?:slight_smile:

Wcmtrl shows like this

~> wmctrl -m
Name: Xfwm4
Class: xfwm4
PID: 22879
Window manager's "showing the desktop" mode: N/A

I tried the yast2 luncher and it doesn’t work but works if I use the terminal.

This is the Xfce 4.18 pre2.

Thanks again.

I don’t think it’s possible to have a usable Xfce session on mutter-wayland. Anyway good luck…let us know if you succeed.

I guess you need to take a step back and start with explaining what you are trying to achieve.

Anyway, when I do the same in a terminal emulator inside of Xfce session I get

bor@tw:~> mutter --wayland --replace
libmutter-Message: 21:22:08.301: Running Mutter (using mutter 43.1) as a Wayland display server
Failed to setup: Could not take control: GDBus.Error:System.Error.EBUSY: Device or resource busy

At least, running “mutter --wayland --display-server – startxfce4” ends up with SEGFAULT in xfce4-session. I can run something simple like xterm or weston-terminal or even xfce4-settings-manager, but in the latter case attempt to launch any setting crashes it.

If it were as simple, we had Xfce under Wayland long ago …

Thanks. I am trying the new xfce 4.18 that will be release in the coming weeks. I am using the pre2 right now and it has wayland support though far from being complete.
Weston is usable as seen here:

I can run all of the application using the weston terminal. Some running application stays inside the weston window and some run outside the weston window or open in the display.

Well, you neither explained what you were trying to achieve nor described what exactly you did. Your screenshot looks like nested weston instance which is started inside some other desktop environment. I do not not know what “usable” means to you, but you can start mutter in the same way.

Some running application stays inside the weston window and some run outside the weston window or open in the display.

Yes, modern desktop is much more than just compositor (or even window manager).


Apologies for not being clear enough. As I mentioned to my previous posts I installed the new Xfce 4.18 pre2 that will be released in the later part of this month (December 2022). Apparently this release will have some wayland suport. I am using mutter x11 from time to time instead of xfwm4 as my windowmanager in xfce so I got curious, what if I try mutter with wayland, but found out it’s not that easy because I lack the knowledge in it on top I am not really using wayland except when I use kde sometimes.

With your comment regarding the image about weston that I included in my last post. That weston compositor screen was run while using the Xfce 4.18 pre2.
I hope this answers what you were trying to know what I am trying to achieve.


To my best knowledge that is not possible simply because you cannot start full Xfce session under Wayland. There was one reddit post 'Hey, it is possible" without a single word explaining how it is possible. And of course, you cannot replace X11 window manager in the active X11 session by Wayland compositor keeping session processes running.

Somebody was working on xfwm fork with Wayland support, last commit in this repository was three months ago, no idea how usable it is. But this is still not enough without full support from other applications.

Apparently this release will have some wayland suport.

No. Some applications in this release may be able to run natively under Wayland or Xwayland. This is by far not equal to “wayland support”.

Fair enough. Thanks again.