Multiple run level entries in grub

Somewhat new to openSuse. Running 12.2
I would like to alter grub menu to have 2 entries.
1 for booting to runlevel 5 and another for run level 3.
When I installed, I set run level 3 and now cant seem to get around it.

One reason, among others, to do this is so I can change my desktop manager. Currently running KDe. I have installed Mate and would like to use it. Everyone tells me to select it when I log in to x. since i start with a command prompt, and then type startx, I dont get the chance to select anything.

So, any ideas?

If this is already a thread, I apologize. Didnt see any that matched this problem

You can change the default runlevel in YaST->System->System Services (Runlevel).

Are you using grub legacy or grub2?

In grub legacy you should have a parameter line at the boot menu where you can just add ‘3’ or ‘5’ to boot to the corresponding runlevel.
You can also edit the file /boot/grub/menu.lst to add a new entry (add “3” or “5” to the kernel line).

For grub2 it’s a bit more complicated to add a new boot menu entry. So please answer first which one you are using.

One reason, among others, to do this is so I can change my desktop manager. Currently running KDe. I have installed Mate and would like to use it. Everyone tells me to select it when I log in to x. since i start with a command prompt, and then type startx, I dont get the chance to select anything.

Run “init 5” and the Login Screen should appear, where you can select the session.
Or change the default session in /etc/sysconfig/windowmanager (DEFAULT_WM). That should be respected by startx.

I am running grub2. Using init5 worked, but would be nicer to just have 2 entries in grub to pick from.

In this case you could edit /boot/grub2/grub.cfg, add the “3” or “5” to the line starting with “linux” there.
But this would be overwritten the next time the bootloader is reinstalled.

For a consistent change you would have to add something to /etc/grub.d/.
Maybe try to use this great script: https://forums.opensuse.org/content/164-gnu-grub2-command-help-config-editor-version-2-01.html

On 09/26/2013 12:56 PM, wolfi323 wrote:
>
> vsreeser;2587839 Wrote:
>> I am running grub2. Using init5 worked, but would be nicer to just have
>> 2 entries in grub to pick from.
> In this case you could edit /boot/grub2/grub.cfg, add the “3” or “5”
> to the line starting with “linux” there.
> But this would be overwritten the next time the bootloader is
> reinstalled.
>
> For a consistent change you would have to add something to /etc/grub.d/.
> Maybe try to use this great script: http://tinyurl.com/bsojlh7

To get what you want, leave your system startup to level 5, but disable
autologin. That way you will get the login page where you can select what
desktop you wish to use.

You could also leave autologin enabled and boot to run level 5. That will get
you the desktop you previously used. To change, logout and select the new one
from the login page.

I do not think changing the grub menus is the best way to go.

Took the easy way out and just reinstalled openSuse. Now, on to wrestling with other problems

vsreeser wrote:
>
> lwfinger;2587863 Wrote:
>> On 09/26/2013 12:56 PM, wolfi323 wrote:
>>>
>>> vsreeser;2587839 Wrote:
>>>> I am running grub2. Using init5 worked, but would be nicer to just
>> have
>>>> 2 entries in grub to pick from.
>>> In this case you could edit /boot/grub2/grub.cfg, add the “3” or “5”
>>> to the line starting with “linux” there.
>>> But this would be overwritten the next time the bootloader is
>>> reinstalled.
>>>
>>> For a consistent change you would have to add something to
>> /etc/grub.d/.
>>> Maybe try to use this great script: ‘openSUSE Forums - GNU Grub2
>> Command Help/Config Editor - Version: 2.01’ (http://tinyurl.com/bsojlh7)
>>
>> To get what you want, leave your system startup to level 5, but disable
>> autologin. That way you will get the login page where you can select
>> what
>> desktop you wish to use.
>>
>> You could also leave autologin enabled and boot to run level 5. That
>> will get
>> you the desktop you previously used. To change, logout and select the
>> new one
>> from the login page.
>>
>> I do not think changing the grub menus is the best way to go.
>
> Took the easy way out and just reinstalled openSuse. Now, on to
> wrestling with other problems
>
>
Easiest way was to disable auto-login :frowning:


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop