Multiple problems with 'Intel' graphics driver in 11.4

I’ve been using Mandriva (and predecessors) for ten years or so, but that distro really seems to be dying at the moment. Consequently, I am trying to move over my various PCs to SUSE.

I’ve started with my EEEPC 901 which has a 945GME integrated graphics chip. Using Mandriva 2010.2 it works fine and I can have desktop effects (built into KDE) running with no problems. However, with KDE on openSUSE 11.4 I get irregular freezes, although I can still work within the focussed window. Moving around though, clicking on other parts of the desktop etc. doesn’t work, then after a few seconds they all happen at once. I am getting the following error multiple times in the X log, which I suspect is associated:

EQ overflowing. The server is probably stuck in an infinite

I note this supposedly fixed bug report that may be relevant:

Secondly, I am getting hopeless 3D speed (glxinfo reports SGI and has all expected output). Desktop effects won’t work at all, on boot it pops up a message saying they are disabled as too slow. I know it isn’t a benchmark, but glxgears gives about 50, it used to give over 500. I remember a few X versions back having to enable UXA mode instead of EXA in the ‘intel’ driver, but presumably that is no longer needed and I cannot see any effect of doing that now (in the xorg.conf.d device file). According to the X log, X is definitely using ‘intel’ driver, not fb etc.

I note the following, supposedly resolved, bug report that may be relevant:

Anyone have any ideas/fixes?

Might be worth a read here if you didn’t
openSUSE Graphic Card Practical Theory Guide for Users

Try the older version of the Intel driver that is referred to as “intellegacy”. You can force the loading of that by an appropriate edit to the /etc/X11/xorg.conf.d/50-device.conf file

Perhaps I’ll give it a try. I read elsewhere that intellegacy is no longer maintained and has other problems on similar chipsets. The 945GME is officially supported with the current driver so ought to work correctly. It’s a real pity there are this many regressions.

I did go through the practical theory guide - before that I was wondering where on earth xorg.conf had got to!

I recommend you be more definitive here. It is VERY easy to try. Is there something you do not understand about trying it?

Also, if instead you try the proprietary Intel IEGD driver and succeed to get it to work, could you write a guide so that others can follow the instructions? The Intel web site clearly states the Mobile Intel® GME965 and GLE960 Express chipsets are supported by the IEGD.

Likewise I am attempting a new install of 11.4 but on a Dell SX280. Same driver problems here although slightly different hardware. It is a 915G chipset but it uses the same drivers, intellegacy/intel.

The intellegacy driver kind of works using the xorg.conf generated, as per the practical theory guide. At least it produces a desktop. It is slow though, and any gtk apps including Firefox, LibreOffice, etc crash X. So basically unworkable. The intel driver does not work at all when used in the same xorg.conf or in xorg.conf.d, dropping back to a console when trying to start X.

I have two similar boxes running 11.2 without this issue. Ive used the xorg.conf from these machines on the 11.4 box. The intel driver fails, intellegacy works poorly as above.

I’ve also tried the xorg.conf.d approach with both drivers as well. Same result as above in each case.

11.2 support ends in a couple of months. Hopefully between now and then a solution becomes available.

The xorg error log for the intel driver failure says the usual “display not found”. Gtk apps crash X immediately, without a trace.

I will certainly post any success with this but after two long days wasted on this, in my little corner of the world it appears that openSUSE 11.4 is terminal. Long live 11.2.

PS, I’ve just noted the bit about the IEGD driver above. Will investigate, thanks.

Yep same problem with intellegacy, KDE comes up but when it tries to start Firefox (autostart as was open when logged out) X crashes. I guess I’ll have to have a go at IEGD. But this is a very large number (in terms of machines) of graphics chips with which openSUSE 11.4 has problems. I’m surprised it was released with these regressions in such a major component.

IMHO this relates back directly to (1) testing and (2) timing. There were recent updates to X and to the Intel driver (to work with the X updates) that the Linux community (and NOT just openSUSE) need to implement. The problem is the older drivers (which may work better on your hardware) do not work with newer hardware. I suspect the ‘hope’ was that the newer hardware would work with the newer drivers / X , but unfortunately users with that hardware did not participate much in the early stages of the openSUSE testing.

If the community with that hardware refuses to support the testing, then its not going to work in openSUSE. Its that simple. Its unfortunate, its sad, but testers are needed else no functionality.

There were regressions with the 11.4 in the kernel (?) or somewhere else in 11.4 GM, which snuck in between 11.4 RC1 and RC2 impacting the openSUSE boot requiring the boot code ‘nomodeset’ for selected AMD (radeonHD) hardware (which in the case of AMD hardware forces a boot from radeon to radeonhd drivers). However that is AMD hardware and this is an Intel driver thread. Unfortunately with Intel hardware, the ‘nomodeset’ boot code forces one back to the very very basic (and slow) FBDEV driver.

We need more users with Intel hardware to test and write guides. For some reason we are not seeing as many users (who own Intel hardware) as we need to write graphic guides to help others. :frowning: We have some users of newer Intel hardware participating on our forum and posting their test results (and feeding what they learn back to the kernel developers) but the number of such users contributing is woefully and pathetically inadequate. :frowning:

What else can one say if there is next to no community testing and no one in the community writing guides ?

Yes, if you have this issue it is a showstopper. How did you install by the way? I downloaded the official kde livecd, installed from that then updated.

As a matter of interest the installer would not delete a couple of 11.1 partitions that I wanted to use for the install. I did this manually then it worked. Also would not recognise two 11.2 partitions in the grub configuration section, requiring manual configuration. This basic stuff, to get a clean install, is beyond most people, I would have thought.

Do you get the crash if you disable special desktop effects ?

I should add I note someone created a guide here - but its not exactly a point and click solution and it would be helpful if someone could create an openSUSE version of that (for example we don’t use ‘apt-get’ in openSUSE) : nanoANT » Blog Archive » Compiling kernel IEGD 10.x module for any Linux distribution

Skimming thru some of the web pages I’ve seen on this does cause me concern that Intel may not have updated this IEGD for the latest X and possibly not for the more recent kernels. Although I do note the latest version is 10.4, with a Release date of February 16, 2011.

They are disabled. As previously noted, it is when a GTK app starts I think (Firefox in my case). I will have a go at the IEGD driver and report back when I get chance. I would suggest that the problems with testers of intel graphics is that most linux users are ‘power users’ and don’t choose fairly rubbish integrated graphics solutions!

I’ve been using Linux for well over ten years so I’m not too worried about getting my hands dirty (ha the hoops I had to go through to get my sound card working in the 90’s).

I also have problems with intel driver and compiz. I’m using Thinkpad T500 with GM45 Express Chipset (got it from hardware information)

When I turn off the desktop effects, everything works fine. But with compiz on, I can boot and desktop comes on, but it is slow and depending on switcher, Alt-Tab switching is either very slow or in case of Appliction Switcher, the switcher graphic does not go away after releasing Alt-Tab. Compiz easily crashes and I’m back to no desktop effects.


Reading the comments on the nanoANT IEGD install method mentioned above (nanoANT » Blog Archive » Compiling kernel IEGD 10.x module for any Linux distribution) suggests that it may not be applicable to kernels > 2.6.34.

There may be some joy here though 915resolution: Intel Video BIOS Hack for some of us (?) intel gfx users who would be happy using fbdev if the right resolution was obtainable. I run openSUSE as a mail and ftp server for a small business so high end graphics is not a requirement. Fbdev certainly works in 11.4 but is very limited in terms of screen resolution, in my case 1280x1024 max on a 1920x1080 display.

I note that 915 resolution was at one stage packaged for openSUSE. It gets around a video bios bug that fails to report resolution modes, and as well allows one to force the correct resolution in xorg.conf. There are a number of posts about it if one searches the forum.

Will report back with any findings.

My intel graphics work perfectly on both my IBM/Lenovo

I reckon we could do with compiling a list somewhere. The 915s seem bad (from other reports), my 945GME works, but has problems, you ??? works fine apparently…

Hat tip (!), the i915 is now working flawlessly. Auto-detected, no xorg tweaks. I have heard that this is not peculiar to openSUSE, but recent experience with KDE46, nvidia drivers and now this suggests we are in a randomised, double-blind crossover trial of gfx cards. Hoping that your drug works and that somebody else gets the placebo.

I have that chipset in my ThinkPad SL510 and it works fine with 11.4 KDE 4.6.0 (including desktop effects), but I haven’t yet tried it with standard Gnome. Should I expect a problems when I do?