Multimedia codecs in Tumbleweed

Hi, I have just re-installed Tumbleweed from scratch and I’m having a little trouble with the codecs. I’ve tried a couple of things:

  1. Using Yast as described in this screenshot: https://opensuse-community.org/images/packman-vendorchange.png (taken from https://opensuse-community.org/ under “GNOME Codecs”).

  2. Through the command line as described in this page: SDB:Installing codecs from Packman repositories - openSUSE Wiki, running the following commands

sudo zypper addrepo -cfp 90 'https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/' packman
sudo zypper refresh
sudo zypper dist-upgrade --from packman --allow-vendor-change
sudo zypper install --from packman ffmpeg gstreamer-plugins-{good,bad,ugly,libav} libavcodec-full vlc-codecs

This seems to be an issue with Firefox only, as I can run videos with the installed video player and with other browsers (Gnome web, Brave).

Any ideas what can be causing this and how to fix it? Thanks!

1 Like

See if this helps…

2 Likes

Thank you, I’ve followed the solutions provided in that thread in order of appearance and managed to get it to work. For future reference this is what I did:

# did nothing on its own
sudo zypper in gstreamer-plugins-bad-codecs 

# showed me an error conflicting with dependencies, selected solution 1
sudo zypper in libavcodec59

Problem: the installed ffmpeg-5-mini-libs-5.1.2-15.1.x86_64 conflicts with 'libavcodec59' provided by the to be installed libavcodec59-5.1.2-15.2.x86_64
 Solution 1: deinstallation of ffmpeg-5-mini-libs-5.1.2-15.1.x86_64
 Solution 2: do not install libavcodec59-5.1.2-15.2.x86_64

Perhaps these steps could be updated somewhere in the portal page to make it easier to find for new users? In any case, thank you for the help!

@chaing you need to select option 1, ffmpeg-5-mini* are from the oss repository.

1 Like

Glad to have been of help. Thanks for the update!

1 Like