multimedia challenge!

I please need some help, I’m trying to set up my parents computer (Tumbleweed) and they’re not able to play some Internet video with Firefox.
Here is the video:

I installed the multimedia codecs by following this guide:

And also Pipelight with this other guide:

In Firefox i get an error: “an error occured while trying to play this video” (roughly translated because the sytem is not set in English).
I tried with Chrome and no problems.
Also no problems with Firefox on Chapeau Linux 23 installation (it’s a Fedora spin which comes with all the codecs preinstalled).

I don’t really know what should I do, so thanks in advance for any precious suggestion :slight_smile:

Assuming you parents are not computer experts. TW may not be the best choice since it constantly changes so has a higher probability of having problems. Just saying…

All codecs must come from packman to be able to play proprietary stuff.

I may think the site I linked could use Microsoft Silverlight technology.
My parents are totally fine with TW, more easy for me to admin… same system as mine, and no need to update dramas every 6/12 months. Computer is just use for browsing the Internet after all.

Apply the switch on Packman
See if that helps

Note that updates for TW come weekly rather then 6-12 months and they can be just as dramatic a change as a new version.


Packman repository is enabled (also for updates).
Is it that what you mean?

no you need to do a full vendor change with packman zypper dup --from <insert packman alies here>, post your repo list

zypper lr -d

also remove pipelight as it maybe causing more issues then it fixes, I tried getting to that site and as far as I can tell it does not use flash (I have flash disabled) or silverlight I did see a video and a huge ad above so I might have seen 2 ads, I do believe you have the crippled version of ffmpeg a dup to packman should fix things.
If all else fails (it shouldn’t) install the windows version of Firefox and Flash (even silverlight) under wine (avoid pipelight)
This in principle

I’m confused guys,
so you’re saying that when I do what is suggested here:
it doesn’t add and enabled automatically Packman? Is not the vendor change asked at the first zypper dup?

I made do I clean re-install before my parents leave, avoiding pipelight and see if I can cleanly do a vendor change.
Sorry for silly questions, hopefully I’ll get better or the codecs situation in Opensuse will too :slight_smile:

adding a repo does not switch packages automatically, and using zypper dup without specifying a –from switch pulls packages from all repo’s, that guide is not bad but it has several issues/bugs, do not replace phonon-gstreamer as it’s better (this is subjective) then phonnon-vlc
this is my multimedia guide in 3 steps copy/paste enabled for all of openSUSE tw/leap/13.x (the example is for tw just change the ftp dir/name for leap/13.x)
#1 add packman

zypper ar -f packman

#2 do a dup to packman

zypper dup --from packman

#3 install vlc-codecs xine-codecs as those packages don’t exist in the oss repo and a dup might not pull them

zypper in vlc-codecs libxine2-codecs

that’s it I don’t need/use libdvdcss2 as DVD’s are dead and I don’t need it’s repo.

I just read
and they do not tell users to do a vendor change to packman, so that site is semi correct, without dup-ing to packman you end up with mixed packages