MSI GE70 brightness keys work... but no control

This is an interesting adventure, hopefully someone here can help out.

System is an MSI GE70-0ND 213US, and has the dual intel/nvidia graphics.

Basically, my brightness keys do work in KDE (it shows the widget and the percentage moving up and down) but the actual brightness does nothing.

A little googleing the “unable to set brightness” ACPI error I got in dmesg brought me info on the acpi_backlight boot parameter.

I’ve tried ‘acpi_osi=Linux acpi_backlight=vendor’ and also with acpi_backlight=legacy to no avail. They squelch the ACPI error, but still no control.

Loading the msi-laptop kernel module also has no effect on the backlight, nor does setting video.use_bios_initial_backlight to 0 or changing acpi.brightness_switch_enabled

I should note that the backlight control DOES work if I kill ACPI completely (acpi=off), and it also worked before I flashed a new firmware. (However, the firmware flash was necessary to regain control of the bluetooth and WIFI devices - the original firmware was for Win8 and did not change the hard-lock on the interfaces when pushing the wifi/BT keys. Downgrading to a firmware meant for Win7 fixed that, but introduced this backlight control problem.)

I guess what I’m looking for is a way to kill any backlight related code from running in the ACPI subsystem so the BIOS can remain in charge of the backlight control. (acpi_backlight=none or off?)

Thanks in advance.

Update: This seems to transcend to Windows as well, no more backlight control there either. Looks like a bug in the firmware.

Weird that it works during the early boot stages (e.g. when POSTing) though.

I don’t see which version of OpenSUSE you’re running. If it’s 12.3, I’m experiencing the same problem on my Toshiba Satellite P750D. Try changing the brightness level using the keys, then log out and log back on and see if the brightness has changed. On my laptop this does work.

Not that it’s a solution for the problem, but hopefully it’ll help troubleshoot.

Hi everybody!

The same problem here, I got a MSI GT683 R laptop, -dual boot- two HDD inside, one runing win7, opensuse 12.3 the other one.

Intel/nvidia; 6Gb RAM

I just want to comment, that running win7, all the function keys plays absolutelly fine, so, there is no reason to justify changes in
BIOS’ machine.

Besides, coming from opensuse 12.1, everything was very easy to fix, you know, sound, fonts, BRIGHTNESS, etc.

Something happened, … kernel?, in my very poor opinion, the problem seems to be nvidia.

But, ladies and gentlemen, I simply, can’t control by any means/ways, the high monitor brightness!

And now, I am evaluating if, I better buy a brightness protection shield, or better run win7 and wait for the next nvidia’s fix.

Have a nice day!

No, the problem is definitely not Nvidia since we’re seeing the same thing with Radeon hardward/drivers.

It looks to me like 12.3 is a no-go for laptops. Drop back to 12.2, that was solid on laptops.