MPlayer can't find DVD drive

openSUSE 42.3. Recent clean install.

All multimedia stuff is from Packman repository except for libdvdcss which is from VideoLAN repository.

VLC plays DVDs fine, no problem. Dragon Player is useless since it can’t access DVD menus like VLC can, so I removed it.

SMPlayer plays everything else - audio and video files - fine except for DVDs. When I try to "Open DVD From Drive: I get this:

 /usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --ao=pulse, --no-input-default-bindings --input-vo-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=65011934 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --sub-ass-line-spacing=0 --sub-scale=1 --sub-font=Arial --sub-color=#ffffffff --sub-shadow-color=#ff000000 --sub-border-color=#ff000000 --sub-border-size=0.75 --sub-shadow-offset=2.5 --sub-font-size=50 --sub-bold=no --sub-italic=no --sub-codepage=ISO-8859-1 --sub-pos=100 --volume=61 --dvd-device=/dev/sr0 --cache=auto --osd-level=0 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=/home/rhack/Pictures/smplayer_screenshots --audio-pitch-correction=yes --volume-max=110 --term-playing-msg=MPV_VERSION=${=mpv-version:}










  --audio-client-name=SMPlayer --term-status-msg=STATUS: ${=time-pos} / ${=duration:${=length:0}} P: ${=pause} B: ${=paused-for-cache} I: ${=core-idle} VB: ${=video-bitrate:0} AB: ${=audio-bitrate:0} dvd://0

 Error parsing option dvd-device (option not found)
 Setting command line option '--dvd-device=/dev/sr0' failed.

 Exiting... (Fatal error)

For some reason it can’t accept /dev/sr0 as an option.

Checking hardware in Yast, the DVD drive is indeed /dev/sr0, as expected.

Changing the default backend to mplayer and trying to open the DVD, Mplayer fails to start and I get this:

"MPlayer/mpv failed to start. Please check the MPlayer/mpv path in preferences."

 /usr/bin/mplayer -noquiet -slave -identify -nofs -sub-fuzziness 1 -ao pulse, -nodr -double -nomouseinput -input nodefault-bindings:conf=/dev/null -nokeepaspect -wid 65012811 -monitorpixelaspect 1 -subfont-osd-scale 3 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/rhack/.config/smplayer/styles.ass -subcp ISO-8859-1 -subpos 100 -volume 56 -dvd-device /dev/sr0 -dvdangle 1 -osdlevel 0 -vf-add screenshot -noslices -af-add scaletempo -softvol -softvol-max 110 dvd://1


Note: The DVD is addresses as 1 in that command. But if I run /usr/bin/mplayer dvd://0 from the command line, it opens and plays the DVD fine. So it seems for some reason running mplayer from smplayer assumes DVD 1 instead of dvd 0. BUT if I run /usr/bin/mplayer dvd://1, it ALSO opens and plays the DVD fine!

If I run this from the terminal:

 /usr/bin/mplayer -noquiet -slave -identify -nofs -sub-fuzziness 1 -ao pulse, -nodr -double -nomouseinput -input nodefault-bindings:conf=/dev/null -nokeepaspect -wid 65012811 -monitorpixelaspect 1 -subfont-osd-scale 3 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -noflip-hebrew -ass-styles /home/rhack/.config/smplayer/styles.ass -subcp ISO-8859-1 -subpos 100 -volume 56 -dvd-device /dev/sr0 -dvdangle 1 -osdlevel 0 -vf-add screenshot -noslices -softvol -softvol-max 110 dvd://1

It runs the DVD fine.

But If I run it from SMPlayer, it gives me “MPlayer/mpv failed to start. Please check the MPlayer/mpv path in preferences.” But MPlayer is in /usr/bin as expected, as is mpv.

I’m out of ideas. I’d like to have SMPlayer functioning as it was in 42.2. I don’t like having to switch between SMPlayer and VLC. I like SMPlayer because it allows me to use the arrow keys to move back and forth in a video. VLC doesn’t use those keys. But if SMPlayer or the underlying mplayer or mpv no longer can play DVDs, it’s not much use to me and I’ll have to stick to VLC.

Any ideas as to why SMPlayer/mplayer/mpv can’t handle ‘–dvd-device=/dev/sr0’?

Can you please clarify something for me, before you go any further ? And my apologies in advance for this silly question - but I had to ask. In smplayer, one can specify under preferences, drive, exactly which dvd drive to use. If smplayer is setup wrong there, then it will go to the wrong DVD drive. Honestly - I can not tell if you went to that GUI location in smplayer.

Case in point …

My openSUSE-42.3 install has two hardware DVD devices - sr0 and sr1. If I have smplayer pointed to the wrong one, it won’t play the DVD. Further, if I have smplayer pointed to just /dev/dvd it will play from one drive and not the other.

To play from sr0 I set this:](

To play from sr1 I set this:](

Please confirm you tried that GUI menu ?

My apologies if your narrative indicated you tried that, but when I read and reread your narrative, I could not tell how deep you went into the smplayer setup gui ?

You’re right, I should have specified that I’ve tried several different settings for that, even though /dev/sr0 is the only correct one. Currently it’s set for /dev/sr0 as expected.

I suppose you could try /dev/sr1 in the smplayer menu in case there is some sort of reversal - although honestly I can not think of one scenario in which that would occur.

Could it be a corrupted config file for smplayer ? I confirmed smplayer DOES play with /dev/sr0 and /dev/sr1 in openSUSE 42.3 LEAP on my PC, so this appears specific to something wrong specifically on your PC.

On my PC I switched all system packages to packman … etc … and you note you have done the same - so one would expect our PCs have the same configuration here - yet yours does not work and mine does work.

So that logically suggests to me that we need to find out what is wrong with your PC setup …

Try deleting .config/smplayer directory. Possibly do that after a deletion and re-install of smplayer. You also could try at same time deleting ./mplayer directory. The idea is to have a clean re-install of mplayer/smplayer with no corrupt config files. Its a long shot , but its good to remove mplayer/smplayer as the possible problem , before one starts to speculate on support apps.

OK, I deleted ./config/smplayer and smplayerrc and uninstalled kplayer (which depends on mplayer), mplayer and smplayer.

Reinstalled and without doing anything else I tried to open a DVD. Same result as the original post.

If I take the mpv command that SMPlayer has passed to mpv and insert it at the command line, I get the same output:

 rhack@linux-xmxj:~> /usr/bin/mpv --no-config --no-quiet --terminal --no-msg-color --input-file=/dev/stdin --no-fs --hwdec=no --sub-auto=fuzzy --ao=pulse, --no-input-default-bindings --input-vo-keyboard=no --no-input-cursor --cursor-autohide=no --no-keepaspect --wid=25165875 --monitorpixelaspect=1 --osd-scale=1 --sub-ass --embeddedfonts --sub-ass-line-spacing=0 --sub-scale=1 --sub-font=Arial --sub-color=#ffffffff --sub-shadow-color=#ff000000 --sub-border-color=#ff000000 --sub-border-size=0.75 --sub-shadow-offset=2.5 --sub-font-size=50 --sub-bold=no --sub-italic=no --sub-codepage=ISO-8859-1 --sub-pos=100 --volume=55 --dvd-device=/dev/sr0 --cache=auto --osd-level=0 --screenshot-template=cap_%F_%p_%02n --screenshot-format=jpg --screenshot-directory=/home/rhack/Pictures/smplayer_screenshots --audio-pitch-correction=yes --volume-max=110
Error parsing option dvd-device (option not found)
Setting command line option '--dvd-device=/dev/sr0' failed.

Exiting... (Fatal error)

If I change the device settings in SMPlayer to /dev/dvd, I get the same error but this time referring to /dev/dvd"

 Error parsing option dvd-device (option not found)

 Setting command line option '--dvd-device=/dev/dvd' failed.

 Exiting... (Fatal error)

It’s almost as if it’s saying that the option “dvd-device” is not an available option.

HOWEVER, I just tried this:

mplayer dvd://1
MPlayer -4.8 (C) 2000-2017 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing dvd://1.
There are 10 titles on this DVD.
There are 1 angles in this DVD title.

And it plays the DVD! If I change the 1 to a zero, it STILL plays the DVD!

If I change the device assignments in SMPlayer to /dev/sr1 - nothing happens. When I say open from DVD drive, absolutely nothing happens. At one point, however, it then prompted me that the devices had not been configured and brought up the device configuration screen. Putting it back to /dev/sr0 just gives me the same error as originally.

Ah, now, here is something: When I switched the multimedia engine to mplayer on the General tab, then SMPlayer popped up a message saying it couldn’t identify what version of mplayer was I using and to specify it. So I clicked “1.03 or newer” (it’s actually mplayer -4.8) and it played the DVD!

That didn’t happen the last time (before the uninstall) I tried switching the multimedia engine. Perhaps the uninstall-reinstall cycle fixed something.

Apparently the mpv backend can’t handle the device assignment, but mplayer can.

I think we’re good now. Thanks for your help.

Great news. I’m wondering if maybe deleting the old configuration files did the trick, where for some reason before the switching the multimedia engine did not apply. or maybe that and the uninstall/re-install together did the trick.

In any event - great news. Glad to read its working now.

Maybe I’m wrong as this may have been changed for LEAP, but IIRC you should use libdvdcss from it’s specific repo, not from videolan as it would work with VLC but be incompatible with others?

In my old, unsupported oS the repo is

nope libdvdcss2 is developed by the vlc people and it makes no difference who compiles it all that matters is that you get the library for your OS ie 42.2 or 42.3 and not mismatch them (although even then it might work) I got it from vlc and use it without an issue
the reason I got it from vlc was I got the url from their site and installed it without adding a repo (o get it from codecguide you have to add their repo as it’s not browsable