Mpeg 1 layer 3 codec

Can anyone help with the command to install the mpeg 1 layer 3 codecs?

Most of the codecs that one will use are obtained by installing the packman packaged version of libffmpeg0. I don’t keep detailed track of exactly what codec is obtained by the dependencies of libffmpeg0 … Before delving into this in any detail, have you installed that ffmpeg/libffmpeg0 application(s) and their dependencies?

i do not know if this will be helpful to you, but it was helpful for me after a fresh install to get all my movies to work.

openSuse forums> Multi-media and Restricted Formats link

If KDE is used, libxine1+libxine1-codecs from Packman are required for mp3 playback, for GNOME these are most likely the gstreamer packages.

I am using KDE and have attempted to install the codecs and still it isnt working and still no sound with the flash player either… :frowning:

Please post result of this from a terminal:

zypper lr -d
justin@linux-e8k6:~/Documents> zypper lr -d
# | Alias                   | Name                    | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
1 | KDE:KDE4:STABLE:Desktop | KDE:KDE4:STABLE:Desktop | Yes     | Yes     |   99     | rpm-md | |        
2 | Libdvdcss repository    | Libdvdcss repository    | Yes     | Yes     |   99     | rpm-md |                                                |        
3 | Packman Repository      | Packman Repository      | Yes     | Yes     |   99     | rpm-md |                                         |        
4 | non-oss                 | non-oss                 | Yes     | Yes     |   99     | yast2  |                        |        
5 | openSUSE-11.2-Non-Oss   | openSUSE-11.2-Non-Oss   | Yes     | Yes     |   99     | yast2  |                         |        
6 | openSUSE-11.2-Oss       | openSUSE-11.2-Oss       | Yes     | Yes     |   99     | yast2  |                             |        
7 | oss                     | oss                     | Yes     | Yes     |   99     | yast2  |                            |        
8 | packman                 | packman                 | Yes     | Yes     |   99     | rpm-md |                                             |        
9 | update                  | update                  | Yes     | Yes     |   99     | rpm-md |                                           |        

In a su - terminal (in this order)

zypper rr 3
zypper rr 2

Try this, but it may be complicated:

zypper dup -r packman

You will need to accept vendor changes.

OR it might be easier from a UI view to go to Yast Software Management and filter the view by repo and do this:

I like commands better but I’m getting this error:

zypper dup -r packman
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
7 Problems:
Problem: nothing provides needed by
Problem: nothing provides gstreamer-0_10-lang = 0.10.28 needed by
Problem: nothing provides gstreamer-0_10-plugins-base-lang = 0.10.28 needed by
Problem: nothing provides gstreamer-0_10-plugins-good-lang = 0.10.21 needed by
Problem: nothing provides imlib2 needed by
Problem: nothing provides needed by
Problem: nothing provides transmission-ui = 1.76 needed by

Problem: nothing provides needed by
 Solution 1: keep cairo-1.8.8-2.1.i586
 Solution 2: break cairo by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c): 

I think you may have to go to the UI
And you need the QT UI because gnome’s GTK UI is terrible.
How To Get QT zypper GUI in GNOME YAST - openSUSE Forums

Try the switcher in the UI as I posted earlier
In gnome recently I temporarily deleted Transmission to get round it. It re-installed without issue.

how do i do this part? its not very clear

Expand System–>Yast2–>GUI–>WANTED_GUI

Change the setting of WANTED_GUI from auto to qt.

Click “Finish”, acknowledge any prompts, and you are done.

Select qt from the drop list](


you may have to logout and back in

okay i did everything and still no sound with flash and mp3’s still dont work.

Please check the guide again
Make sure you have the correct repos and perhaps go thru the 10 step check

Caf4926, I find this sort of problem painful to read.

In truth it is INCREDIBLY easy to setup mp3 and flash on openSUSE, but some how new users simply feel above the need to read our stickies and they are above the need to read documentation, and intead they read next to nothing, and they then manage to install incompatible repositories, and then mess up settings after a fresh install instead of this taking the few minutes it takes you or me, they get totally stumped.

I’m not sure what is to blaime here. Possibly it is too easy to add repositories and it should be harder? Maybe the 1 click install is to blaime ? Or maybe its just new users who refuse to read and follow our forum guide before they destroy their laptop’s settings.

Maybe 7justin7 needs to be pointed to the location in YaST where they switch their system repository to Packman and apply all Packman packages instead of packaged from other repositories. Then have them check their ability to play mp3 in more than one app … ie check xmms, smplayer, xine, vlc, AND amarok, and not just check with 1 or 2 players and then claim mp3 do not play.

I think we may need to create a better guide for debugging audio in flash. I have rarely had a problem with this. The only times I did were on openSUSE 11.1, once when I installed a community CD which required a symbolic link to get 64-bit flash functioning, and a couple of times on 11.1 where libflash-support had to be removed. But for 11.2, I find the problems typically are:

  • PCM volume control being overlooked. It needs to be moved up high
  • settings in KDE > Configure Desktop > Multimedia are inconsistent with settings in YaST > Hardware > Sound
  • settings in KDE > Configure Desktop > Multimedia have wrong back end applied, or if xine backend is applied, user has not installed libffmpeg0 (from packman) , libxine1 (from packman), and xine-ui(from packman). On rare occasions its been necessary with xine-ui for users to change audio setting from “auto” to “oss”.
    *]settings in firefox > edit (?) > preferences > application > shock wave flash file are set wrong

Painful. Yes.
I had an issue with Flash once. The playback was slightly slow, but it turned out to be a delay in updates in Linux. But 99.9% of the time in 32 or 64 bit it just works for me.
mp3 etc… takes me about 5 mins to install the packages from my guide. Works every time.

I have a feeling we explained the switcher already.

caf4926 I do appreciate all of your help, I really do. I will try and do all that you have said. I have gotten mp3 codecs to work in many other distro’s but for some reason I am having a difficult time with opensuse. I will defintely go through the posts again and double check I have done everything correctly.

Take a look at your installed packages like this. Yast - Software Management
View filter by Repositories

It should open by default on ‘System’
Leave it like that.

Scroll through all you packages.
How many Red colour versions do you see. (For example, libdvdcss should show Red and should be orphaned - that is with no provider.) But are there many others?