moving from /home to another partition dolphin error

hi, on my laptop using leap 15.2 and KDE when with dolphin I move a file from /home to another partition NTFS formatted and mounted as /dati in fs tab in this way:

UUID=6336f8b2-7520-4a75-9bdd-929df5de67f3  /home      ext4     data=ordered  0  2
UUID=2E46E1B173FD89D1                      /dati      ntfs-3g  user,users,gid=users,fmask=113,dmask=000  0  0

if I move the file /home/belquadro.jpg to /dati/plax/ it result in this error:
but the file is moved and I can see in /dati/plax and also in /home, but if I click on cancel the file seems to be still there in /home and also in /dati/plax, but if I refresh dolphin the file disappear from /home
how can I avoid this error?

It’s hard to know what happened, without more information.

Generally, when you move a file from “ext4” to an NTFS file system, you are likely to get some error messages due to the incompatibility of permissions between the two file systems.

It is a bit confusing. Is it moved in the end or not?

In any case, looking at your fstab entry, I am wondering about some of the mount options.

You have the file sytem independent mount options:

  • user, which means an ordinary user to mount the file system (and then only that same user can umount it);
  • users, which means any user to mount and umount it, no need to umount by the same user that mounted it.

Now, as I read it, the second implies the first. Thus why have both?

Then you have some ntfs-3g file system dependent mount options. From the man page:

uid=value and gid=value
Set the owner and the group of files and directories. The values are numerical. The defaults are the uid and gid of the current process.

Which means that gid=users is incorrect. I have no idea if that is ignored or set to some ? value. Why trying to set it at all?

You could at least check what the results of these options are with

ls -l /dati

the strange is that the error is referred to /home partition and the deleting in /home, if I move from /dati/plax to /home no error pops up, also if I move from /home to smb://userme@ or to sftp://userme@ and also no errors vice versa
it seems like a too quick move…

yes!! it is moved

I don’t remember, if the second implies the first I will try to remove “user”

I remember to have red something in internet, I remember to have set it in this way (and it seems to works) to have any file transferred in /dati by any user accessible by any other user in users group, and if transferred to and from another place like smb://userme@ have the group set to users, in I cannot find that “the values are numerical” but only in ntfs options session “**uid=**value, **gid=**value and **umask=***value
*Set the file permission on the filesystem. The umask value is given in octal. By default, the files are owned by root and not readable by somebody else.”
do you refere to other man pages?

it’ too long all /dati, I can give a subfolder of /dati like this:

pla@pla4-TW:~> ls -l /dati/plax/VITTORIA/
total 104
drwxrwxrwx 1 root users  4096 May  7  2019 batteria computer portatile
-rw-rw-r-- 1 root users 44219 Jun 13  2020 IL PISELLO PICCOLO DEL NARCISO 27 MAGGIO 2020-correzioni.odt
-rw-rw-r-- 1 root users 35346 Jun  9  2020 IL PISELLO PICCOLO DEL NARCISO 27 MAGGIO 2020.odt
-rw-rw-r-- 1 root users 17823 Apr 25  2020 IL PISELLO PICCOLO DEL NARCISO.docx

I guess you looked in

man mount

but there you only find options for ntfs. You use ntfs-3g, which has it’s own man page

man ntfs-3g

And as you see files are owned by user root, because you did not specify any other user (with uid=) and root did the mount.
When the mount was done using another user (which is allowed because of the users option), that user would have been owner (again because nothing else specified).

Apparently gid=users seems to work as if you used the GID of users, even if it is not correct reading the man page.

Btw, it is better to read man pages then “somewhere on the internet”.