Mouse too fast after upgrade from 42.1 to 42.2

I have just upgraded from 42.1 to 42.2 (using Plasma). My mouse settings are exactly the same as before but the mouse pointer moves way too fast.

Is there a way to slow it down additionally using some other settings?

Perhaps the advice in this archlinux wiki page will be helpful to you.

Thank you!