Mouse settings

Using XFCE. Can someone please point me to a mouse tutorial. When I set it using Settings>Mouse and Touchpad it’s always too sensitive and too fast. A 10cm. move shifts the pointer the entire screen, and frequently it starts applications that get in the way. I have tried with both Microsoft and generic mice.

Any suggestions will be appreciated.

This reference may be useful to start with
https://wiki.archlinux.org/title/Mouse_acceleration#Mouse_acceleration_with_libinput

You can use ‘libinput’ (assuming ‘libinput-tools’ is installed) to get device attributes…

sudo libinput list-devices

Find out in Yast2-Software Management if you can find something to control your mouse.
In my case, I have a logitech mouse and I use “solaar” for my mouse config. Solaar is for logitech mouse and it support my mouse model.

Thank you for the speedy response. You have always been very helpful. I will delve into the problem when I have time to navigate the complicated changes. But I have a simple question. Setting up a keyboard for a new computer or installation is simple and fast. Why is it not the same for such a necessary input device? Is that a problem only with XFCE?

Question. Do you see the same problem when outside XFCE? E.g. in the login screen?

Well I did find something called perl-MouseX-SimpleConfig. “Simple” is not exactly as it says. It involves the installation of 32 additional files to work. I hesitate installing complicated dependencies that require repeated updates. Perhaps buying a Logitech mouse is a simpler solution.

Interesting question. Yes the same problem at the login screen.

I don’t use XFCE, so can’t comment from that perspective. However, underneath the hood, most such input devices are now handled via libinput, and can be configured different ways as described in the wiki page I linked to. Pointing devices such as mice come with a bunch of different capabilities, so sometimes it’s necessary to tweak as required for optimal use.

Can you provide some hardware details concerning your mouse?

/usr/sbin/hwinfo --mouse

Also

grep -i "using input" /var/log/Xorg.0.log

That may help others to offer more specific advice.

Then you answered your own question:

Is that a problem only with XFCE?


:~> grep -i "using input" /var/log/Xorg.0.log
    24.900] (II) Using input driver 'libinput' for 'Power Button'
    25.190] (II) Using input driver 'libinput' for 'Video Bus'
    25.233] (II) Using input driver 'libinput' for 'Power Button'
    25.257] (II) Using input driver 'libinput' for 'HID 046a:0001'
    25.299] (II) Using input driver 'libinput' for ' USB OPTICAL MOUSE'

Thanks for the help and advice. It’s not that I am lazy. I will get around to the long-winded solution. It’s a new motherboard on my desktop #2 and I am trying to get more important software updated and up to speed.

Yes indeed!

All good. It’s not hard…you can test adjusted settings on the fly via a terminal eg for a mouse listed as input device 11

xinput --set-prop 11 "libinput Accel Speed" -0.7

A similar thread discussing the same approaches as the arch wiki page details…
https://www.reddit.com/r/voidlinux/comments/gwnc3m/mouse_speed_in_xfce_libinput/

I found a simpler solution. I logged into XFCE as root, which I don’t like to do, and found that I could change all the mouse settings. Now a comment. I try to solve my problems without having to install additional software (e.g. xinput) that doesn’t come with a normal installation. Otherwise I have to list everything extra I installed and re-install again it at a later time.Thanks for all the suggestions, and I’m sorry I took up your time when the simple solution was so obvious.

Well, logging in as root in the GUI is never “a simple solution” :frowning:

And I am at loss at what you changed there. Desktop settings (and I assume that is also true for XFCE) are for the user. Changing things in root’s desktop will not change the same thing for other users.

But as you say you are satisfied, please enjoy.

What I changed as root was the setting under Settings>Mouse and Touchpad so that the mouse behaved as I wanted it (as root). Yes I know the theory is that changing root’s settings won’t change user’s settings. But as I did not modify anything as suggested by other posters AND the mouse behaves the way I want it to behave as user, I can only presume that it has been an “act of god”. By the way, I see your use of the word “assume”. Many years ago a wise old man told me that using the word “assume” frequently results in making an “ASS” of “U” and “ME”. But thanks for the advice and input. I will keep it in mind.

Hopefully this kind of problem will be gone in the next xfce version that will be release in December.
Some of the new enhancements are available now in the tumbleweed xfce repository.
I heard it is going to have a wayland support.