Mouse pointer with multiple monitor


I tried for almost one day to configure my new laptop with my external screen. I am almost desperate : I have OpenSuse 12.1 and I want to use two screens (the one of the laptop and an external one) as an extended desktop. Everything works except that the mouse cursor disappear always on one of the two screens (I can click but the cursor is invisible) : when I change a little bit the configuration (for example I desactivate one of the two screen and I reactivate it), the screen where the mouse pointer is invisible can change. I have a graphic card intel HD 4000. I tried with “intel legacy” and with xf86-video-intel 2.17.0 release found in Intel Linux Graphics: 12.02. I tried also to activate the software cursor by option “CursorSW” “on” but it does not solve anything. Moreover, the problem occurs in any windows manager, it occurs also in “mirror mode” (I see the mouse only on one of the two screens), and it also occurs on the login screen.
I would be very thankful if somebody has another idea.


I have a work laptop, (using an older intel graphics chipset and intel driver), that I sometimes use with an external monitor. I don’t experience the problem you’ve described though. Which desktop environment are you using?

I am using gnome. I finally solved the problem (which was independent of the desktop environment) by installing xf86-video-intel-2.19.0 (which is not the one officially recommended for my configuration).


Great. Thanks for the update. It may help others who come searching. :slight_smile:

Thanks Idemonet for posting this problem. As you are a new user like myself, I doubt you will be back to help, but to anyone else listening I have a very similar problem if not exactly the same.

I have a gateway MT6821 which has an Intel 945GM graphics adapter.
I have tried various Linux distros over the years but the result always leaves me with a mouse cursor that sometimes works.
On openSUSE 12.1 it takes this form… If I have my desktop display on the laptop’s built-in display everything seems to work fine. As I don’t use this setup very often I can’t say for sure it’s okay.
If I stretch my desktop over my laptop’s VGA connection and the built-in display, again everything seems to work fine. Again I don’t use this setup very often.
If I output only to the external VGA and disable the built-in display my mouse cursor disappears. The mouse is still working and active but the cursor is invisible.
If I try the ctr+alt+f1 and ctr+alt+f7 fix as I have read to do the mouse cursor comes back for about 2 secs and disappears again.
If I try the alt+f2 workaround my mouse then finally stays visible.

I’m new to linux. I know “app get install”. I know what a repository is. I know what a tarball is, but that’s about it.
I have messed around a little with my NAS’s busybox and using VI and that’s just really copying what I’ve read online…
I am a windows user since Intel DX2.I am trying to change that but it’s next to impossible to learn a new OS when the mouse keeps disappearing.

Please help.