Mouse and keyboard not working

I had Leap 15.1 installed on my PC when I had Win 7 on it (dual-boot). I later installed Windows 10, and that screwed up Grub. I never bothered to repair it until recently. I installed Tumbleweed over it (formatted /, but left my /home partition alone). Now, when I boot, I get to the login screen, but my USB mouse and keyboard are unresponsive. The lights on the mouse are lit, but they lights on the keyboard are not. Neither works at all. Does anybody have any idea what I can do to get them working again? I obviously can’t get to any logs or anything, since I can’t interact with my system at the point. When I reboot to Windows, both work fine.

My system used an Intel CPU, and NVIDIA RTX 2070 Super. Both devices are plugged directly into the usb ports on the mother board, not the front of the case or an external hub.

Plugging mouse and keyboard into the connectors of the main board is the preferred option. You need to do some forensics. Boot into a live or rescue system and post your findings.

Have you tried using different USB ports (despite your declaration that the keyboard and mouse work with Windows). I assume that the keyboard works at the grub screen at least?

Another thought…examine the UEFI/BIOS and check if IOMMU Controller is enabled. (I’ve read of similar symptoms with some Gigabyte MBs.)

An old thread I recalled regarding IOMMU…
https://www.linuxquestions.org/questions/linux-hardware-18/no-keyboard-or-mouse-in-linux-4175651198/#post5979678
and another similar thread…
https://unix.stackexchange.com/questions/72625/why-is-usb-not-working-in-linux-when-it-works-in-uefi-bios

Yes. I’ve tried different ports. I’ve also tried disconnecting all other USB devices. The keyboard does work at the GRUB screen.

This looks promising. I do, in fact, have a Gigabyte motherboard that is several years old. I’ll read these when I get home and check them out. I’ll respond with my results.

Apparently, based on those threads, IOMMU is an AMD specific setting. My motherboard does not have that setting. However, it led me to the correct solution for my motherboard, which is an Intel motherboard. I had to disable XHCI completely. Once I did that, the mouse and keyboard worked correctly.

Thanks for the links though, they gave me the hint I needed to figure it out.

Well done. Good to read of your success with this.

Yet another Gigabyte-related thread…
https://forums.opensuse.org/showthread.php/528858-Gigabyte-GA990FX-Gaming-Motherboard-OpenSUSE-Leap-42-3-USB-2-0-Ports-Non-functional-3-0-Fine