Mounting VFAT devices.

I have just installed openSUSE 11. It is a while since I have used SUSE, and I have to say it is absolutely beautiful.

It does everything I need it to, apart from automatically mount my LG Viewty.

When I connect via USB in mass storage mode I get an error - unable to mount volume, stating that the device uses a the vfat file system that is not supported.

My phone mounts perfectly in Windows, and two different Linux installations, PCLinuxOS and eeeXubuntu. I also was able to happily mount the device using a Mint Live CD.

I cannot mount from the command line for the same reason, complains that VFAT is not supported.

I don’t know whether

a) I simply need to install the right software from the repositories


b) I need to set up mount points, perhaps fiddling with fstab (note, I’m not that familier with doing that!)

Judging by the error message I’m assuming (a), but searching for installable software I cannot find anything that strikes me as providing VFAT support!

Can anyone help me? I installed from the Live Gnome CD, so possible if I had installed from full DVD this may not have happened.


I can’t think what’s wrong. Vfat automounts i 11 for me. It’s a fundamental property of Suse for years. I wonder what Suse is seeing. can you post here the output from this console command entered into Gnome Terminal:

sudo /sbin/fdisk -l

Thanks. I will do tonight.

I was having the same problem with an internal floppy and a usb floppy drive. After updates on 7/18/08 and rebooting the problem went away.

sudo /sbin/fdisk -l


Disk /dev/sda: 20.0 GB, 20000000000 bytes
255 heads, 63 sectors/track, 2431 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000d76e2

Device Boot Start End Blocks Id System
/dev/sda1 1 96 771088+ 82 Linux swap / Solaris
/dev/sda2 * 97 1050 7663005 83 Linux
/dev/sda3 1051 2431 11092882+ 83 Linux

That shows the device is not being detected at all. It should show as sdb1. Was it connected when you executed the fdisk command?

Weird. It just works now.

I took a load of updates this morning, and also installed kernal-kmp because I needed ndiswrapper.

Now I just plugged the phone in and it worked.

So I have no idea at all! Could be some of the updates, but don’t know why I got them later than wsx123.

Thanks anyway.

Just another Linux mystery.