Mounting Samba drive in fstab

New version of Opensuse, new issues with accessing a samba share on the network…
Have got a number of Samba shares, on a Fritz!Box router, which I am loading like:
// /home/External/data cifs noauto,username=john,password=xxxxxxx,vers=1.0,iocharset=utf8,sec=ntlm 0 0
Worked fine with Leap15.
Have also tried with vers=2.0 and also removing any ref to vers.
Can anyone recommend how I now access this using Leap15.1?


More info:
If I: sudo mount -v /home/External/data/
I get:
mount.cifs kernel mount options: ip=,unc=\\FRITZ.NAS,vers=1.0,iocharset=utf8,sec=ntlm,user=john,prefixpath=Seagate_Expansion_Drive/data/,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs) and kernel log messages (dmesg)
Very little (understandable) info in any of the logs…


Permission denied
Usually means you’re trying to access something that doesn’t exist or has permissions you haven’t provided.
There can be many causes for not providing credentials to address permissions…
Bad username/password.
Incompatible ciphers (encryption algorithm) used. Perhaps 15.1 is using a newer version than your server by default, so you need to specify accurately in your configuration file.

You can look for more specific information in your server (Fritzbox) logs.
You can also try displaying your system log events on your client machine in real time as you try to connect by opening a console/terminal window (like konsole or xterm) and running the following command-

journalctl -f


Anything significant reported via the following?

sudo  journalctl | grep CIFS

Forgot to mention…
Since my post describes User mounted and not mounted on boot,

I recommend you follow my procedure first to make sure your mount command works,
Then after you’ve verified it works insert into your fstab.


Sorry peoples…
How many times can you read a “wrong password” message and ignore it…
All my fault from being stupid!
My apologies to Samba!! >:(

All working as expected.

At least you’ve identified the mistake with credentials! Thanks for the update. :slight_smile: