mounting HPFS/NTFS file system


I tried to install Solaris 10 on my laptop but after successfully installation, it showed me an error related to Xserver which I couldn’t resolve and I installed openSuse 11.0 kde based. There was Window Vista already installed on my system but after openSUSE installation now it is not showing in the boot menu.

I tried to mount my harddisk partition using partitioner but it is showing me the following error.

“Error: It is not allowed to assign a mount point to a device with nonexistent or unknown file system.”

The output from fdisk -l is:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000656dd

Device Boot Start End Blocks Id System
/dev/sda1 2 5238 42064896 7 HPFS/NTFS
/dev/sda2 10459 19457 72282112 7 HPFS/NTFS
/dev/sda3 * 5239 10458 41929650 83 Linux

Partition table entries are not in disk order

(sda1 :: vista partition, sda2 :: just to store my data and sda3 :: linux)

I tried to mount it
mount -t ntfs -r -o umask=0222 /dev/sda2 /media/sda2

but it is also giving me an error.

mount: wrong fs type, bad option, bad superblock on /dev/sda2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

the msg I got from dmesg | tail is:

NTFS driver 2.1.29 [Flags: R/W MODULE].
NTFS-fs warning (device sda2): is_boot_sector_ntfs(): Invalid boot sector checksum.
NTFS-fs error (device sda2): read_ntfs_boot_sector(): Primary boot sector is invalid.
NTFS-fs error (device sda2): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
NTFS-fs error (device sda2): ntfs_fill_super(): Not an NTFS volume.

I don’t know what to do now. Its a lots of project and data stored on my hard disk which i don’t want to loose.

Any help is appreciated.



look here

I tried to mount it temporary but got the following message:

mount -t ntfs-3g /dev/sda2 /media/sda2

NTFS signature is missing.
Failed to mount ‘/dev/sda2’: Invalid argument
The device ‘/dev/sda2’ doesn’t have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?


edit your

you need to use sudo - use one of the following depending if you are kde or gnome:

kdesu kwrite /etc/fstab
gnomesu gedit /etc/fstab

add the following

/dev/sda2 /media ntfs-3g defaults 0 0

Ideally you should create a folder in your tree to mount to. Above we have just used the existing /media folder
You could always create a folder within /media called sda2 or whatever you want.

In which case it would look like:

/dev/sda2 /media/sda2 ntfs-3g defaults 0 0

when done - reboot

I tried this way but its not mounting any partition.

content of fstab files are:

/dev/disk/by-id/scsi-SATA_WDC_WD1600BEVT-_WD-WXE108K42535-part3 / ext3 acl,user_xattr 1 1
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/sda2 /media/sda2 defaults 0 0


did you create the folder sda2 in /media

and make sure there is a return after the last line in your fstab

yes, I did create a sda2 in /media and there is a return after the last line in fstab.

shouldn’t that last line read

/dev/sda2 /media/sda2 ntfs-3g defaults 0 0

maybe there is some confusion here as often vista setups have that hidden recovery partion perhaps that is what you have been trying to mount, this is just a guess however!!!


I deleted hidden recovery partition. I believe my NTFS partition got corrupted by Solaris installation.

correct; as I quoted earlier in point 4 (don’t know why I missed that)

/dev/sda2 /media/sda2 ntfs-3g defaults 0 0