mount.nfs: access denied by server while mounting


I have a Thecus NAS with nfs support runnig.

Now I switched from OpenSUSE 10 to 11.2 on the client side and aren’t able to mount my nfs shares. With SuSe 10.0 I didn’t have any problems.

The /etc/exports:

On the client side I’m able to see the shares:
*showmount -e nas1
Export list for nas1:
The client adress:
inet addr:

I’m using nfs-3:
mount -t nfs nas1:/raid/soundandmore /mnt
mount.nfs: access denied by server while mounting nas1:/raid/soundandmore

What’s wrong?


I am reading back- and forward through your post trying to find what you didn’t. No success until now, but one thing I found a bit strange (though I do not think it is realy wrong). for a subnet. Why the 24? One normaly puts there zeros (0) for the last 31 bits (bitmask). Like (and for the next subnet in the network). I do not say that that is the error, but it makes reading/interpretation not easier.

I know, that’s a little bit strange, but the front-end of my NAS (Thecus) doesn’t accept an address range out of the range, which is used in the local network.
Thecus is using a linux system, which looks a little bit strange to me. If I’m editing /etc/export, I don’t know how to make the changes active. There is no export command. And if I reboot the system the changes are lost.
But with this exports-file, it was working with an old SuSE version.

Thanks for replying.

IMHO when you change something in /etc/exports, you do a

exportfs -a

to make it active (see man exportfs). and of course at a reboot the same is done automaticaly. I never heard about a file exports-file.

But in any case, when the client askes the server and the server answers with what is has (as you showed in your first post), one should think that mounting is possible.

Did you use nfs-3 in the client on openSUSE10.x ?

That subnet spec is really weird. actually means only the addresses and Since the first is the network address, and the last a broadcast address, this is a useless subnet. And everything else on the subnet is out of range.

More likely it should be

Did you actually read that off the Thecus or did you set it up that way in the web interface.

Sorry, to be not clear enough. I know how to use the exportfs command, but the linux on the Thecus NAS server doesn’t have it.

Yes, I 'm nearly sure, that I used nfs-3 at my old installation.

It’s really strange, because “showmount” gives me the export list.
But your comment gives me the idea to check the nfs-version on the server again.

mount -t nfs4 nas1:/raid/soundandmore /mnt
mount.nfs4: Protocol not supported
mount -t nfs nas1:/raid/soundandmore /mnt
mount.nfs: access denied by server while mounting nas1:/raid/soundandmore

On the server side I tried to find out the version of the nfs deamon, but I didn’t find anything in the log files.

So I tried to find something under /proc, but my linux know how is to less. Is 2049 the port for nfs? Can I use the port with the mount command?

nas1:~# cat /proc/fs/nfsd/versions
+2 +3 +4
nas1:~# cat /proc/fs/nfsd/exports

Version 1.1

Path Client(Flags) # IPs

nas1:~# cat /proc/fs/nfsd/portlist
ipv4 tcp 2049
ipv4 udp 2049

Thanks for your support.

I advise stringly to read ken_yap’s post. Because that subnet is wrong. I think he is right, this is a typo and it should be

My first reaction was: hey, strange. But I did not realy put it thruogh the calculator. But:

Address:          11000000.10101000.00000000.0001100 0
Netmask: = 31  11111111.11111111.11111111.1111111 0
Wildcard:               00000000.00000000.00000000.0000000 1
Network:       11000000.10101000.00000000.0001100 0 (Class C)
Broadcast:          11000000.10101000.00000000.0001100 1
HostMin:          11000000.10101000.00000000.0001100 1
HostMax:          11000000.10101000.00000000.0001100 0
Hosts/Net: 0                     (Private Internet)

Maybe fraba_88, you think that 24/31 means 24 to 31. It doesn’t. /31 is a prefix length. See this page:

Classless Inter-Domain Routing - Wikipedia, the free encyclopedia

Dear all,

thanks a lot for your support. I was some days skiing, so I didn’t reply.

Really i thought, it’s the range. Here the description of the NAS-System:

All host please set ‘*’
other host ‘’
host range ‘’

Of course, with /24 it’s working.
But now I don’t understand why I was able to mount it with my old Linux-System.

Thank you again for your patience.

Let us worry about your problem and go skiing, what? But we have ice for skating here!

‘Host range’ is a strange way of putting it. Maybe they thought that by not using (sub)net they thought they would make it clearer >:)

For your old Linux system I hav of course no explanation, but I would bet something was chaned on the server.

I had to go - I always do what my wife is saying >:). Sometimes it could be that I’m a little bit hard of hearing. :wink:

Reading the Wiki, it makes it really clear, I must have changed it.