Mount MicroSD

I am trying to mount a micro SD adaptor with a 64GB micro SD - this is the error message:

 An error occurred while accessing '62.5 GiB Removable Media', the system responded: The requested operation has failed: Error mounting /dev/sda1 at /run/media/root/432E-8C16: Command-line `mount -t "exfat" -o "uhelper=udisks2,nodev,nosuid,uid=0,gid=0,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077" "/dev/sda1" "/run/media/root/432E-8C16"' exited with non-zero exit status 32: mount: unknown filesystem type 'exfat'
 

If I run

 # sudo mount /dev/sda1 /mnt

I get: mount:

unknown filesystem type 'exfat'

as it was likely formatted in windows

Any help much appreciated/

Hi
Grab the fuse-exfat and exfat-utils packages from the filesystems repository;
https://software.opensuse.org/package/fuse-exfat
https://software.opensuse.org/package/exfat-utils

Thanks - I used what I had already installed (dosfstools) and just ran

 # mkdosfs -F 32 -I /dev/sda1

. Worked fine. Thanks for your prompt reply…

Hi
As long as you don’t try to put any big files on it, you will be fine :wink:

Why no big files? And if I do what is better?

FAT is 16 bit and limited to 4 gig files maxsize . exfat/FAT32 is extended and does not have the 32 bit limitation. NTFS is ok also for large files. If used only on Linux then use ext2/4

So I have my mounted car. I can access it using Dolphin, copy files to it etc, but if I try and, say, ‘browse’ to the folder where it is in the system /run/media/root/A322-EAE8/ cos I want to create a ‘Tresor’ there I don’t see anything. Probably file permissions but Dolphin won’t let me change them even tho I’m logged in as root.

You should not be logged in as root

Permissions on MS file system are synthetic and not persistent ie you can not change them.

I really did not follow what you are doing please explain step by step