Monitor gets turned off when vlc is playing videos (openSUSE 12.1)

My monitor turns off when playing videos in vlc player. KDE problem?

Using openSUSE 12.1 kde amd64.

Power management cannot solve this issue. ( windows & ubuntu oneiric has no problem like this)

It seems playing a video is treated as the system is idle.

I would appreciate if you come up with a solution.

Thanks in advance.

Disable screensaver

My settings
SUSE Paste

I forgot to mention screensaver turned off, dim display & screen energy saving =1 Minute,
I did it because it helps when downloading torrents.
I dont want to change power settings 3 times a day & that settings works for ubuntu oneiric

I think SMPlayer then will work better for you

I have the same issue with vlc so I decided to check the ~/.config/vlc/vlcrc file’s contents and found out that it has this settings:

# Inhibit the power management daemon during playback (boolean)
# Disable screensaver (boolean)

As you can see inhibit and disable disable-screensaver options are enabled but commented out. This is the default state (when the corresponding checkboxes are checked in the settings dialog). When you disable this in settings dialog that options become uncommented and disabled:

# Inhibit the power management daemon during playback (boolean)
# Disable screensaver (boolean)

So I guess that default behavior of the player is to disable the screensaver and inhibit the power manager but for some reason it fails to work right.
I tried to leave those settings uncommented and enabled and it seems to solve the problem.

# Inhibit the power management daemon during playback (boolean)
# Disable screensaver (boolean)

But still player behaves quite strange: I tried using it three times with the manually edit vlcrc file and first time screensaver started but only after I quit the fullscreen mode, focused another window then got back to vlc. Other two times everything worked fine so it may be just a one-time bug but I’ll continue testing and post any info found here.
Please note that every time you change something in the settings dialog all this lines will revert to their default state (figure 1) if corresponding checkboxes are checked and to (figure 2) if not so you’ll have to edit them manually again.

P.S. Also corresponding to the console output that vlc uses xdg-screensaver to control screensaver and it reported that it was unable to find a window with the specified id but still screensaver was disabled that time.
Hope this helps.

Everything seems to be ok for the second day so I guess the previous post may be a solution at least a temporary one.
And note for moderators: don’t you think this thread should be moved from the ‘hardware’ section to ‘multimedia’ or ‘applications’?