Mobile broadband Globetrotter HSDPA modem


I have this usb stick:

Datakort navn: GlobeTrotter HSDPA Modem
Applikasjons port: COM3
Firmware versjon: 2.5.13Hd (Date: Feb 18 2008, Time: 18:32:40)
Maskinvareversjon: 2.0
FPGA versjon: ikke relevant
IMEI nummer: 359741018554481
Egne telefonnummer: ikke relevant
IMSI nummer: 242010105133606
Serienummer: DR2985V4KW
Programvare test
Programvare versjon:
Operasjonell test
PIN-kode status: Klart
Nettverksnavn: TELENOR (24201)
Nettverksvalg modus: Automatisk
Signalstyrke: 14,0
Start mobil radio: På
Gjeldende mobil radio: På
GPRS innstillinger
Registrering mot GSM nettet: Ikke registrert
Registrering mot GPRS nettet: Ikke registrert
Tilkobling til GPRS nettet: ikke relevant
APN: ikke relevant
UMTS Innstillinger
Registrering mot linjesvitsjet UMTS: Registrert
Registrering mot pakkesvitsjet UMTS: Registrert
Tilkobling til pakkesvitsjet UMTS: Vedlagt
APN: 1,“IP”,“telenor”,“”,0,0
WLAN Innstillinger
Tilgjengelig WLAN innen rekkevidde: ikke relevant

The problem is that I have no clue what information I am supposed to give when configuring it through KNetwork manager. The password is disabled and I think the username should be telenor which is my ISP, the other info lines in KNetwork manager, however, I am very uncertain of, and I can’t seem to get it working. I have switched from traditional setup with ifup to user controlled through Network Manager and the modem is detected. The module option seems to be loaded and the ‘mode’ of the stick seems also to be correct, it is not detected as a storage device at least.

Any help is very much appreciated:)

English translation of output suggests no obvious info (to me at least):

Hardware Test
Data name: Globetrotter HSDPA Modem
Application port: COM3
Firmware version: 2.5.13Hd (Date: Feb 18 2008, Time: 6:32:40 p.m.)
Hardware Version: 2.0
FPGA version: not applicable
IMEI Number: 359741018554481
Own phone: not applicable
IMSI Number: 242010105133606
Serial Number: DR2985V4KW
Software Test
Software version:
Driver Version:
Operational test
PIN Status: Clear
Network Name: TELENOR (24201)
Network selection mode: Automatic
Signal strength: 14.0
Start mobile radio: On
Current mobile radio: On
GPRS settings
Registration to the GSM network: Not registered
Registration to the GPRS network: Not registered
Connecting to the GPRS network: not applicable
APN: not applicable
UMTS Settings
Registration to the line-switched UMTS: Registered
Registration to the packet-switched UMTS: Registered
Connection to the packet-switched UMTS: Attached
APN: 1, "IP", "telenor", "", 0.0
WLAN Settings
Available WLAN in range: not applicable

Are you sure you’re not getting connected? Maybe its just a DNS issue?

In the absence of any user familiar with your network operator-specific settings, I used google to find this:

Carrier APN Settings - ModMyi - Wiki

I note that it mentions:

Telenor (Norway)

APN: Telenor
Username: your telephone number
Password: your telephone number

Did you try this with capital ‘T’?

Another reference has this entry

  • Service Provider: Telenor (and every provider on Telenor’s network)
  • APN: internet

Its going to take further experimentation on your part. Thats about all the advice I can offer.


Thanks Deano, but I haven’t succeeded getting it working. Have tried all sorts of combinations but it just hangs on accessing >>>>. APN should be the only variable of uncertainty, the password is disabled and username and telephone number is the same which I got confirmed on Telenors MAC troubleshooting guide, there isn’t much official help for linux customers. I presume I have to call Telenor on Monday.


I presume I have to call Telenor on Monday.

Let us know how you get on.

FWIW, network manager sometimes gets the connection process wrong (for some hardware), so you may also want to try connecting with wvdial or kppp dialling utilities.

On OpenSuse 11.3 I have just checked this with gnome; and kde should be the same;

if one inserts the broadband device;
perhaps first you open a terminal; and copy and paste this into it

dmesg | grep tty

if you see ttyUSB0 and ttyUSB1 and others, you should be fine to proceed further;

if so; close your terminal and on desktop;

right-click on network manager and select Mobile broadband from the tabs; and then Add;
OpenSuse then asks to clarify if GSM or other; you surely need to select GSM,

you then have to do a manual entry of the apn setting; (other distros have the apn settings already installed and available to choose from);
so you need to know the apn settings of your provider; the listed Telenor provider in Norway that I can find has an apn setting of internet; the username and password do not seem to need entries;
so I would suggest entering internet as the apn setting for Telenor;

you then complete the configuration; and close it;

now left-click on network manager; and left-click on the Telenor entry that hopefully shows; and hopefully you can connect if there is money credited to your account;

is any of this of any help?

I briefly tried to use kppp but had no luck. It was a bit more complex as well so I am likely to have made some mistakes. Wvdial complained about not finding /dev/modem (I think it was) and didn’t start, I presume I can manually configure, or pass an argument in Konsole pointing wvdial to /dev/ttyS0(?) instead. I’ll try that later if nothing else work.

I don’t see ttyUSB0 or ttyUSB1, instead I see these two ttyS0, ttyS1. I tried your suggestion pdc_2 without any entries in the username column which I don’t think I have tried, as I was quite certain that it should be the phone number. The test failed with APN set with various examples including Telenor, internet, telenor.

However, while writing this response I unplugged the USB stick on this machine (currently running XP) and plugged it into my second computer, also running OS 11.2 and which I use for testing, to get some info which I wanted to give as reference to what module it use etc. and include that in this reply. I had started KNetwork Manager before I plugged the stick in and, voilà, there it was, it connected. This was pure luck as it seems that I had to insert the card after I had edited the info give in KNetwork Manager(?).
And it was pure coincidence that the last attempt should be the correct one:)

Here is what I had to fill in:

Phone Number: Corresponding to the subscription
User name: (blank)
Password: (blank)
APN: Telenor

Thanks guys!

Thanks for the update. It looked like a config issue, so its good to know what worked .