Mixing audio-in into the audio output

I have an external Bluray player, connected by HDMI with my monitor, and my PC is connected by DVI. The monitor has an analog audio output jack so that I can connect my speakers to it. This already worked, but I don’t want to unplug/plug the speakers all the time from monitor to computer. Unfortunately, there seems to be no way, now and later, to watch Bluray under Linux. (Not after you inserted a recent Bluray and get all keys invalidated.)

The easy way, I thought, would be to connect the audio-out not to the speaker directly but to the audio-in of the PC, and the stereo audio output of the PC goes to the speaker. In Windows this is working perfectly.

                     |              |     
                   audio-out        +->audio-in
BD-Player ==HDMI=> Monitor  <== DVI=== PC -----> Speaker 

In Linux I cannot get the audio-in mixed into the output. In simple words: Can’t hear anything from the player.

Some research taught me that the way is to configure pulseaudio. It does not know that I want to listen to my audio-in. The suggestion is to load the loopback module.

pactl load-module module-loopback

However, when I do that, the sound starts to go in circles. It seems to be fed back from the audio output into the audio-in, creating nice trance-like echo effects from the PC output (echo-cho-cho-cho-eff-cho-eff-cho-eff-ects-cho-eff-cho-ects-ects) while I still don’t hear anything from the player.

Any ideas?

If you are using pulseaudio you need to install paprefs and use it to enable simultaneous sound .

Don’t know the answer to your question, but I have heard mention of pavucontrol often and was not actually aware of the wealth of information at the pulse audio section of the freedesktop website.

for instance:

I think it is definitely possible to do the right way but have you tried something like the mixer in windows?

Hope that helps,


Used to be several versions back the mic input was echoed by default. Did you try paprefs as suggested. I have never used it but it may be what you are looking for.

OK, going to try paprefs. Thanks to all, I’ll report whether this works.

It surprised me to find that something that was trivial two decades ago (mixing audio-in into the output) now seems to require studying the details of a system component…

It sounds like you are using the mixer in windows. Pavucontrol offers similar, if not better, functionality (from the description).

Also; Alsa Opensrc Org - Independent ALSA and linux audio support site

and, Search

have a good day,



I tried pavucontrol, but that was not really successful. I’ll report when I find something new.

It’s still trivial: just disable PulseAudio in YaST->Hardware->Sound->Other->PulseAudio Configuration (or uninstall it completely).

That’s what I do here, as I have no need for PA’s features anyway.

You may have to unmute the corresponding audio sources in alsamixer or your desktop’s volume control afterwards, but then they should just be mixed into the audio output. Works fine here, without any special configuration.

I cannot help you with PA’s configuration though unfortunately. As I said, I don’t use it at all…