Missing Wayland Display Server

After update the lastest version of OpenSuse Tumbleweed 20190614, on the LogIn screen there is two Gnome Sessions, but the both starts only Xorg Display Server. The output are :

#loginctl :
SESSION UID USER SEAT TTY
1 1000 ivonenchev seat0 tty2
c1 460 gdm seat0 tty7
2 sessions listed.

#loginctl show-session 1 -p Type
Type=x11

$echo $XDG_SESSION_TYPE
x11

loginctl :

SESSION UID USER SEAT TTY
2 1000 ivonenchev seat0 tty2
c1 460 gdm seat0 tty7
2 sessions listed.

#loginctl show-session 2 -p Type
Type=x11

$echo $XDG_SESSION_TYPE
x11

ID=“opensuse-tumbleweed”
ID_LIKE=“opensuse suse”
VERSION_ID=“20190614”
PRETTY_NAME=“openSUSE Tumbleweed”
ANSI_COLOR=“0;32”
CPE_NAME=“cpe:/o:opensuse:tumbleweed:20190614”
BUG_REPORT_URL=“https://bugs.opensuse.org
HOME_URL=“https://www.opensuse.org/
LOGO=“distributor-logo”

How can I fix it?

Personally, I haven’t dived deep into Gnome for some time so don’t know if anything has changed and AFAIK both Wayland and the xorg X server components are supposed to be installed by default… nothing new should have to be installed if you switch from one to the other.

Here is the current LEAP documentation which should in almost all cases apply to Tumbleweed as well…

Gnome 3.0 general display and login
https://doc.opensuse.org/documentation/leap/gnomeuser/html/book.gnomeuser/cha.gnomeuser.start.html

More detailed description of the packages you’d expect to see that support xorg X server
https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.gui_desktop.html

If you have an nVidia or ATI GPU, you may need to install additional driver-related packages.
From the above, you might start by inspecting what packages are installed or available but not installed with the following text strings in the package names…

X11
xorg
xf86

TSU

Check /etc/gdm/custom.conf and make sure that ‘WaylandEnable=false’ is commented out…

#WaylandEnable=false

The output of /etc/gdm/custom.conf includes follow rows:

GDM configuration storage

Note: settings from /etc/sysconfig/displaymanager have a higher priority

[daemon]

Uncoment the line below to force the login screen to use Xorg

#WaylandEnable=false

[security]

[xdmcp]

[chooser]

[debug]

Uncomment the line below to turn on debugging

#Enable=true

Okay, that reads as expected.

Post the output of the following

dir /usr/share/xsessions
dir /usr/share/wayland-sessions
grep -i exec /etc/alternatives/default-xsession.desktop
grep -i exec /etc/alternatives/default-waylandsession.desktop

Please enclose within

 /CO... tags.

I will just note that I am able to start a Gnome Wayland session without problems.

If I select an “SLE Classic” session, I get X11, but with Leap 15.1 that selection is also Wayland. But just the entry for “Gnome” (in the GDM menu) gives me a Wayland session. I tested this in a KVM virtual machine.

The issue in this thread is once you have Gnome Wayland working, to then launch Gnome running xorg instead.
For some reason, the @OP is seeing two Gnome Desktop selections, but neither seems to launch xorg instead of Wayland.

TSU

I think you’ve got that backwards. The OP can only launch Xorg Gnome sessions.

You’re right.
I’m mixing up threads.

TSU

The output from dir /usr/share/xsessions is :

total 44
lrwxrwxrwx 1 root root   42 Jun 12 19:47 default.desktop -> /etc/alternatives/default-xsession.desktop
-rw-r--r-- 1 root root 7669 Jun 13 02:08 gnome-classic.desktop
-rw-r--r-- 1 root root 7651 Jun 12 19:47 gnome-xorg.desktop
-rw-r--r-- 1 root root 6820 Jun 12 19:47 gnome.desktop
lrwxrwxrwx 1 root root   13 Jun 12 15:06 icewm-session.desktop -> icewm.desktop
-rw-r--r-- 1 root root 2560 Jun 12 15:06 icewm.desktop
-rw-r--r-- 1 root root 7368 Jun 13 02:08 sle-classic.desktop

The output from dir /usr/share/wayland-sessions is :

lrwxrwxrwx 1 root root   48 Jun 12 19:47 default.desktop -> /etc/alternatives/default-waylandsession.desktop
-rw-r--r-- 1 root root 7614 Jun 12 19:47 gnome.desktop
-rw-r--r-- 1 root root   94 Mar 28 03:15 weston.desktop

The output from dir grep -i exec /etc/alternatives/default-xsession.desktop is :

Exec=gnome
TryExec=gnome

The output from grep -i exec /etc/alternatives/default-waylandsession.desktop is :

Exec=/usr/bin/gnome-session
TryExec=/usr/bin/gnome-session

That checks out as expected. I’m running Leap, but my findings match Neil’s findings. In short, it’s not clear to me why you can’t launch a Gnome Wayland session.

Hi
I’m assuming the OP is running an nvidia gpu…?

I pulled mine here (even running it with no opengl files) so only the intel gpu running and wayland is back…


loginctl 
SESSION  UID USER     SEAT  TTY 
      1 1000 usernamel seat0 tty2

1 sessions listed.
loginctl show-session 1 -p Type
Type=wayland

Hi
And I see this little snippet here: XWayland + Gnome-Shell 3.32 Wayland Usage - Linux - NVIDIA Developer Forums

Also add to the kernel boot options;


nvidia-drm.modeset=1

Edit/usr/lib/udev/rules.d/61-gdm.rules and rem out the nvidia blacklist.


cat /usr/lib/udev/rules.d/61-gdm.rules

# disable Wayland on Cirrus chipsets
ATTR{vendor}=="0x1013", ATTR{device}=="0x00b8", ATTR{subsystem_vendor}=="0x1af4", ATTR{subsystem_device}=="0x1100", RUN+="/usr/lib/gdm/gdm-disable-wayland"
# disable Wayland on Hi1710 chipsets
ATTR{vendor}=="0x19e5", ATTR{device}=="0x1711", RUN+="/usr/lib/gdm/gdm-disable-wayland"
# disable Wayland when using the proprietary nvidia driver
DRIVER=="nvidia", RUN+="/usr/lib/gdm/gdm-disable-wayland"

Hi
So tested above and now have GNOME, GNOME Classic and GNOME on Xorg back in the gdm menu and can switch between both with the nvidia card running… :slight_smile:

I am using Bumblebee. What should I do to receive the login menu as usual.

Hi
I would try the same.