Missing Monitor on Login

Running Tumbleweed. Recently upgraded in late June 2023, and again 20230707.
Also upgraded this dual boot PC to Leap 15.5 from 15.4, in late June.

Integrated Graphics RS780L (Radeon 3000) - radeon driver
Discrete GPU RX560 - amdgpu driver
kde plasma with X11

All displays and monitors show and configurations save

4 monitors
Left - Center - Right

Left is driven by the Integrated HDMI port
Center (HDMI), Right (DVI) and Under (DP - HDMI) are driven by the Discrete GPU card

Left was rotated 90 right and Right was rotated 90 degree left

After: Issue Started in Late June
Issue 1) Only 3 monitors show
Left is missing (Integrated graphics)

Issue 2) Right Monitor will not rotate
tried to use xrandr output, but it fails
something like invalid transformation…

I read in a forum that amdgpu must load before radeon. If so, how is that done?

some more info:

jchufar@localhost:~> xrandr -q
Screen 0: minimum 320 x 200, current 5760 x 2160, maximum 16384 x 16384
DisplayPort-0 connected 640x480+0+957 476mm x 268mm
640x480 62.65 + 60.00* 59.94
1920x1080 60.00 50.00 59.94
1280x720 60.00 50.00 59.94
720x576 50.00
720x480 60.00 59.94
HDMI-A-1 connected primary 3840x2160+640+0 800mm x 450mm
3840x2160 30.00*+ 24.00 29.97 23.98
4096x2160 30.00 24.00 29.97 23.98
1920x1200 30.00
1920x1080 60.00 59.94 30.00 24.00 29.97 23.98
1600x1200 30.00
1680x1050 59.88
1280x1024 75.02 60.02
1440x900 59.90
1280x960 60.00
1360x768 60.02
1280x800 59.91
1152x864 75.00
1280x720 60.00 30.00 59.94 29.97 24.00 23.98
1024x768 75.03 70.07 60.00
800x600 72.19 75.00 60.32
720x480 60.00 59.94
640x480 75.00 72.81 60.00 59.94
720x400 70.08
DVI-D-0 connected 1280x1024+4480+213 376mm x 301mm
1280x1024 60.02*+ 75.02
1280x800 60.02
1152x864 75.00
1280x720 60.02
1024x768 75.03 60.00
800x600 75.00 60.32
640x480 75.00 59.94
720x400 70.08

jchufar@localhost:~> xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x46; cap: 0x0 (); crtcs: 5; outputs: 3; associated providers: 0; name: AMD Radeon RX 460 Graphics @ pci:0000:02:00.0
output DisplayPort-0
output HDMI-A-1
output DVI-D-0
Provider 1: id: 0x9a; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 2; outputs: 2; associated providers: 0; name: ATI Radeon 3000 Graphics @ pci:0000:01:05.0
output 0x98
output 0x99

Missing Monitor Issue)
The HDMI monitor connected to provider 1 is not listed in the xrandr query.

Rotation Issue)
jchufar@localhost:~> xrandr --output DVI-D-0 --rotate left
xrandr: output DVI-D-0 cannot use rotation “left” reflection “none”

The ‘Missing Monitor’ does show on the boot screen - all 4 monitors show the boot screen and the ‘Tumbleweed’ Logo, then when the Login screen displays, the 4th Monitor (Left) disappears (no display).

File: /etc/sysconfig/displaymanager
Possible Values: Xorg or any value
Default Value: Xorg


System Settings - Startup and Shutdown - Login Screen (SDDM)
Already Clicked ‘Apply Plasma Settings’ - no effect.

dmesg > dmesg2.txt
grep vga dmesg2.txt
[ 0.337356] pci 0000:01:05.0: vgaarb: setting as boot VGA device
[ 0.337356] pci 0000:01:05.0: vgaarb: bridge control possible
[ 0.337356] pci 0000:01:05.0: vgaarb: VGA device added: decodes=io+mem,owns=none,locks=none
[ 0.337356] pci 0000:02:00.0: vgaarb: setting as boot VGA device (overriding previous)
[ 0.337356] pci 0000:02:00.0: vgaarb: bridge control possible
[ 0.337356] pci 0000:02:00.0: vgaarb: VGA device added: decodes=io+mem,owns=io+mem,locks=none
[ 0.337356] vgaarb: loaded
[ 5.357621] amdgpu 0000:02:00.0: vgaarb: deactivate vga console
[ 13.768351] radeon 0000:01:05.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=none
[ 13.768362] amdgpu 0000:02:00.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=none:owns=io+mem

Integrated Graphics address: pci 0000:01:05.0
GPU address: pci 0000:02:00.0

jchufar@localhost:~> lspci | grep VGA
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS780L [Radeon 3000]
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] (rev cf)

jchufar@localhost:~> lsmod | grep amdgpu
amdgpu 11689984 1
iommu_v2 24576 1 amdgpu
drm_buddy 20480 1 amdgpu
gpu_sched 57344 1 amdgpu
drm_ttm_helper 16384 2 amdgpu,radeon
ttm 102400 3 amdgpu,radeon,drm_ttm_helper
video 73728 2 amdgpu,radeon
i2c_algo_bit 20480 2 amdgpu,radeon
drm_display_helper 212992 2 amdgpu,radeon

jchufar@localhost:~> lsmod | grep radeon
radeon 2072576 2
drm_ttm_helper 16384 2 amdgpu,radeon
ttm 102400 3 amdgpu,radeon,drm_ttm_helper
video 73728 2 amdgpu,radeon
i2c_algo_bit 20480 2 amdgpu,radeon
drm_display_helper 212992 2 amdgpu,radeon

Any ideas on how to get the Integrated Graphics monitor to also display in KDE?
It displayed OK, until recent upgrades of Tumbleweed.

Old Radeons of your elder’s vintage seem to be suffering regressions lately, likely due to developers not using such old hardware any more. I recently reported two: Mageia bug 32066 and Redhat bug 2220717. I haven’t found a problem with any of my old Radeons on TW, yet, but I’ve never tried to use two at once either. Your issues could be fallout of whatever seems to have gone wrong as manifested in my reports.

Please, whenever posting command output, enclose it in PRE tags (</> icon above input window), and include both the full command line itself, as well as the following shell prompt, so that we have full and readable context of what you’re presenting.

Another bit of command input/output, run from Konsole in TW, should be helpful: inxi -GSaz. In Leap, inxi is an older version that may include some -G brokenness.

Also, a reinstall of tumbleweed helps in the most cases, I did update to 6.3.7. and in both times the 2 GPUs stopped working, together, if I installed nvidia, but returned after a fresh install of Tumbleweed.
A simple snapper revert does not work for me.

regarding the monitor orientation, there an some issue,

I do use horizontal screen when I am mobile and and also
multi GPU screens.

The issue with many distribution is actually, that you have to watch out for the correct numbering of the monitor output.

I still have a eyefinity 6 radeon 6950HD in the office connected to 6 screens.

You are not free to choose a random mix of screens.
Not possible:
1 4 2
6 3 4
To get this running I can only do
1 2 5
3 4 6
Other placement will crash the driver.

Now with my radeon 4600H + nvidia 1660ti I just experienced the issue again
I cannot place
3 2
1 [notebook screen]
I must place them
1 2 3 or

2 3
to get them to work.

The missing orientation also seems to be a returning bug,
Try if you can rotate neighbouring ports, to change

Also, a working workaround, to only use the discrete GPU is to get a DP MST adapter, like the one here, DP to 2x DP or 2x HDMI,

Linux Multi Monitor Laptop with USB-C Display Port MST Multi Stream Technology Adapter 5 screens - YouTube ](Linux Multi Monitor Laptop with USB-C Display Port MST Multi Stream Technology Adapter 5 screens - YouTube

And actually

if you need multiple screens, I fully and finally ended my request for more screen estate, by switching my
6x 22" 1080p screens against 2x 4k 43" screens. Enough space for everything, and mostly no issues with graphics drivers.

jchufar@localhost:~>  inxi -GSaz
  Kernel: 6.3.9-1-default arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.3.9-1-default
    root=UUID=10d45a68-b022-4164-b844-8c86e4a29d60 splash=silent quiet
    amdgpu.cik_support=1 radeon.cik_support=1 mitigations=auto
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: openSUSE Tumbleweed 20230707
  Device-1: AMD RS780L [Radeon 3000] vendor: Gigabyte driver: radeon v: kernel
    alternate: amdgpu arch: TeraScale code: R6xx/RV6xx/RV7xx
    process: TSMC 55-65nm built: 2005-13 ports: active: none off: HDMI-A-1
    empty: VGA-1 bus-ID: 01:05.0 chip-ID: 1002:9616 class-ID: 0300
  Device-2: AMD Baffin [Radeon RX 460/560D / Pro
    450/455/460/555/555X/560/560X] vendor: XFX Pine Polaris 21 XL
    driver: amdgpu v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm
    built: 2016-20 pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3
    speed: 8 GT/s ports: active: DP-1,DVI-D-1,HDMI-A-2 empty: none
    bus-ID: 02:00.0 chip-ID: 1002:67ef class-ID: 0300 temp: 54.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: radeon
    unloaded: amdgpu,fbdev,modesetting,vesa dri: r600 gpu: amdgpu,radeon
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5760x2160 s-dpi: 96 s-size: 1524x571mm (60.00x22.48")
    s-diag: 1627mm (64.07")
  Monitor-1: DVI-D-0 pos: middle-r res: 1280x1024 hz: 60 dpi: 86
    size: 376x301mm (14.8x11.85") diag: 482mm (18.96") modes: N/A
  Monitor-2: DisplayPort-0 pos: bottom-l res: 640x480 dpi: 34
    size: 476x268mm (18.74x10.55") diag: 546mm (21.51") modes: N/A
  Monitor-3: HDMI-A-1 pos: primary,top-center res: 3840x2160 hz: 30 dpi: 122
    size: 800x450mm (31.5x17.72") diag: 918mm (36.14") modes: N/A
  API: OpenGL v: 4.5 Mesa 23.1.2 renderer: llvmpipe (LLVM 16.0.6 256 bits)
    direct-render: Yes

Device 1 is the card that does NOT display

Monitor-1 is the monitor that will not rotate.

Everything worked until last month.

cik_support options are supposed to apply only to Sea Islands GPUs, which are GCN-2 and not what you have. I would try removing those options from your Grub linu line. I’m not sure whether those options continue to be supported or necessary at all in recent kernels.

Current TW version in OSS repo is 23.1.3, so maybe another dup will help.

This is the older (2008) card.

Using which kernel? Is that kernel still installed to try?

I removed the cik_support lines - no change

The MESA version may be locked due to steam, will double check, but just a simple display should not be impacted by mesa

I do not have the older kernel still available…

Not a big deal.
It was great while it lasted.

I will get by with the 3 monitors on the GPU card.

Maybe later this year get a new MB and GPU.

Will try a fresh TW install next.

GCN-2 iGPU runs 4 displays here:

# pinxi -GSaz --vs --zl --hostname
pinxi 3.3.27-27 (2023-07-06)
  Host: ara88 Kernel: 6.3.9-1-default arch: x86_64 bits: 64 compiler: gcc
    v: 13.1.1 parameters: BOOT_IMAGE=/boot/vmlinuz root=LABEL=<filter> noresume
    ipv6.disable=1 net.ifnames=0 radeon.cik_support=0 amdgpu.cik_support=1
    consoleblank=0 preempt=full mitigations=off video=1440x900@60
  Desktop: Trinity v: R14.1.0 tk: Qt v: 3.5.0 info: kicker wm: Twin v: 3.0
    vt: 7 dm: 1: TDM 2: XDM Distro: openSUSE Tumbleweed 20230705
  Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: ASRock driver: amdgpu
    v: kernel alternate: radeon arch: GCN-2 code: Sea Islands
    process: GF/TSMC 16-28nm built: 2013-17 ports: active: DP-1, DVI-D-1,
    HDMI-A-1, VGA-1 empty: none bus-ID: 00:01.0 chip-ID: 1002:130f
    class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: fbdev,modesetting,vesa dri: radeonsi gpu: amdgpu display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3600x2640 s-dpi: 120 s-size: 760x557mm (29.92x21.93")
    s-diag: 942mm (37.1")
  Monitor-1: DVI-D-1 mapped: DVI-D-0 pos: top-right model: Dell P2213
    serial: <filter> built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  Monitor-2: DP-1 mapped: DisplayPort-0 pos: primary,bottom-l
    model: Acer K272HUL serial: <filter> built: 2018 res: 2560x1440 hz: 60
    dpi: 109 gamma: 1.2 size: 598x336mm (23.54x13.23") diag: 686mm (27")
    ratio: 16:9 modes: max: 2560x1440 min: 720x400
  Monitor-3: HDMI-A-1 mapped: HDMI-A-0 pos: top-left model: NEC EA243WM
    serial: <filter> built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  Monitor-4: VGA-1 mapped: VGA-0 pos: middle-r model: Lenovo L2251x Wide
    serial: <filter> built: 2011 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 474x296mm (18.66x11.65") diag: 559mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  API: OpenGL v: 4.6 Mesa 23.1.3 renderer: AMD Radeon R7 Graphics (kaveri
    LLVM 16.0.6 DRM 3.52 6.3.9-1-default) direct-render: Yes

So, there could be a fix to be found if you report this as a regression bug.

You might try first disabling KScreen2 in Plasma startup, then manage displays manually via xrandr/arandr. Upstream 5.26 had a lot of changes regarding multiple displays because of a multitude of multiple display bug reports, that have since kept on coming in 5.27.

Had to Unlock ALL Mesa updates, that would not previously update due to Steam dependencies?

The Mesa packages are from Packman. I cannot even remember why I needed the Packman repos.

After 2 more updates, everything is now awesome once again, as Tumbleweed, normally is!