Missing FreeNX under OpenSuSE 11.1

Not sure as to whether this is the forum for this sort of posting but it is network related. I was wanting to install FreeNX under OpenSuSE 11.1. I know that it is definitely available under 11.0 (use it a lot but I have upgraded) but it seems that the packages aren’t included on either the ISOs nor the OSS repositories. I have done a quick search of the forums and there is no mention of anyone having issues with it not being available.

I have also checked the BuildService and it does have it there BUT the links that it points to to download indicate that the packages are non-existent.

Does anyone know where I can get a hold of it or is there any plans on making available for 11.1? Or, has it been replaced with something else?

Oh, for those who haven’t tried it or are still using VNC - give it a go, it is heaps faster and offers a whole pile of benefits over VNC.

It’s available as a one-click here



Thanks, but as I mentioned I have already been to the BuildService - if you notice the links in the BuildService don’t work for the downloads for the package (including OneClick, which points to the links for the individual packages).

I tend to avoid doing the OneClick thing as I have several boxes to put it on and downloading it multiple times seems to be a waste.

Not sure as to whether anyone can pick this up with the BuildService guys but it seems that they have a missing set of packages on their hands.

You could try nomachine that’s what i use


Yes, I do use NoMachine on some boxes but the problem with the server side of things is that it is limited to only two users - the first two users that login to the system. With FreeNX there is no limit to the number of users and the boxes that I am wanting to use it on have way more than two users.

However, don’t get me wrong, the NoMachine server/client setup is great and works but their pricing isn’t (then again everybody is entitled to make a buck in some way). :\

I have the same problem. Tried to install FreeNX in Suse 11.1 using “Install Software” but it was not available. So I went ant installed FreeNX from 11.0 repo. Today I tried to do the same thing but now FreeNX-0.7.2-18.1.i586.rpm is gone from the 11.0 repo.
Is this something that SUSE no longer supports in it’s repository?

Index of /repositories/NX/openSUSE_11.1/x86_64

I am trying to install freenx but 1-click install is giving me an error so no able to do that I followed all the recommendations but none of them are working).

As well, I need to instal cacti and I could not find it either.

please, could you tell me What should I do to install those two apps? I am configuring a new server and I am stucked.

I manually installed all pre-required software and it did work. I was able to install freenx using Index of /repositories/NX/openSUSE_11.1/x86_64

for nx client I will install the nomachine one

Now, to install cacti should I install it manually or is there any 1-click?

to be honest, I was not expecting that kind of changes from 11.0 to 11.1 as all those packages were available under 11.0.


You do not have to install dependencies manually. Goto yast->repositories and add as URL
Index of /repositories/NX/openSUSE_11.1
with name like NX to your repositories.
Then go to Software Management and search for nx to find freenx etc.

The URL seems to be

Index of /repositories/X11:/RemoteDesktop/openSUSE_11.1

now. I really don’t know why they keep moving it around.