Missing application icons (top-left corner of app)

Hi all,

I decided to switch from KDE to Gnome so I just installed the 3 gnome patterns to get there. I left the KDE stuff for now while I’m testing. Everything appears to work correctly however I’m missing the icon in the top left corner of the applicaion. The one where you can get the application menu.

Here is a screenshot of the Gnome Todo app in a VM with the icon.

And here is the same app on my live desktop using the same theme and icon set.

I even tried creating a new user on this desktop and the problem remains there. Any ideas how to fix this? Let me know if you want any info at all. :slight_smile:

Are you running Wayland or Xorg? If you create a test user and login as that user, doe the issue duplicate?

Hi Malcolm,

I’m running in Xorg and I did indeed try creating a test user. The issue is the exact same there. So I don’t think this has anything to do with my user files but something in the system. What are your thoughts?

Apart from the usual works here (Leap 15.1 and Tumbleweed), which isn’t helpful to you, likely something still missing system wide since it doesn’t work with a new user.

If you open a terminal and run gnome-todo -d, any errors? If not, then press atl+F2 enter lg and press enter (this opens Looking Glass) to right select windows, in the list do you see gnome-todo, any errors? To exit Lokking Glass, press the esc key.

No errors reported with Looking Glass (didn’t know that was there, nice).

$ gnome-todo -d
Unknown option -d

Oh also, I wanted to mention that the issue is not just with Gnome Todo. It’s all apps. I just used that one as an example since I need to get to the menu that hidden to change an option. Lol

Ahh ok, so what patterns did get installed?

I just clicked the following 3 patterns in Yast and hit go. Lol. Everything in basic got installed. In the other 2 there a few that didn’t get installed but they are all just applications that I’m not going to use and also didn’t get installed in my test VM.

Gnome Desktop Environment (Basic)
Gnome Desktop Environment (Wayland)
Gnome Desktop Environment (X11)

Can you try with the default theme?

I see this, even with a theme;

Screenshot from 2020-04-27 11-10-38.png

Hi Malcolm,

The test I ran in the new user did use the default theme. I didn’t change any settings in that new user, I just created it and logged in so I could see if it was a user level problem or not. So I don’t think it has anything to do with the theme or settings in my user profile at all.

I can try running another test if you like with a newly created user again.

So your VM is a pure gnome install or a mixture? Did you test with Wayland as well? For theme setup, your using gnome-shell extensions, themes in ~/.themes, icons in ~/.icons and fonts in ~/.fonts?

Thanks for all of the help Malcolm! :slight_smile:

Yes, the VM is basically a vanilla install. I was using it to test if I wanted to switch to gnome or not and the only thing I really did was to install Gnome (not mixed environment), change it to dark mode, and install a couple of extensions. As for the theme and icons, it’s the default just using dark mode in both the VM and live.

On the test user I created on the live computer, there are no changes from the defaults at all. I have tried Wayland as a test although I can’t use it permanently since I use Autokey extensively for work.

I just found this and tried the 2 solutions listed there but no luck. It’s not exactly what is happening to me but I haven’t found anyone else having this exact problem.

I suspect that this has something to do with KDE still being installed. I was hoping to not have to do a full reinstall to switch. Ugh. I am going to be removing the KDE stuff soon but I have a couple of things that I haven’t transferred over to Gnome apps like email. Once I finish that I’m going to remove KDE and see if that helps.

Any other ideas?

Many thanks!

On the main system what sort of graphics card?

I changed back to default and global dark… all looks good (this is a qemu machine with nvidia gpu).

Screenshot from 2020-04-27 17-50-32.png

On my main machine is Tumbleweed and intel gpu it to works fine.

Good morning Malcolm!

On the problem machine, it’s running Intel graphics. Before installing Gnome on my main computer I actually ran a couple of tests. I first checked things out in a VM. Then I installed on a slightly older computer with similar hardware as this one. That old computer is also using Intel graphics and that problem doesn’t exist there either. It’s just on this one machine. Ugh.

Any other information that would be helpful?

Many thanks!

It’s a head scratcher for sure…! Is the new intel graphics? Can you post the output from;

/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

It certainly is a head scratcher! I may end up having to just do a fresh install but I’m going to try some more things first and I really appreciate your second set of eyes. :slight_smile:

On the Intel graphics. It is a newer one I think. It’s got a 10th gen Intel CPU and I had to install Kernel 5.3 to get some of the hardware to work. Here is the PCI info.

$ /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:8a52] (rev 07)
    Subsystem: Dell Device [1028:097c]
    Kernel driver in use: i915
    Kernel modules: i915

I have my email moved over to Evolution now so I’m going to try removing a lot of the KDE packages later this evening. Hopefully that will have some effect. We’ll see I guess.

Well I removed basically everything that had to do with KDE, Plasma, and Qt but that didn’t fix the issue. :frowning: It’s really odd and I’m stuck unless anyone else has any ideas. I may just wait until 15.2 is released and reinstall then because it’s not a huge issue. It does cut off a couple of settings in some apps and it’s really annoying though. Lol.

Any other ideas on what I can look for or do?

If you can live with until Leap 15.2 (which will have the 5.3 kernel) is released, if it is newer hardware, then do wonder if it’s some of the underlying libraries, GNOME and the hardware.

I wonder if your try a Leap 15.2 USB Live release of GNOME and see if it works better?

Just a final update on this. I ran another test in a VM where I did a default install of KDE and then switched it just like I did on my live computer and the result was the exact same thing. That little icon is missing from all windows that use it in the VM too. So some kind or library or setting must be getting messed up (or maybe not installed) when you do it that. Lol.

I still can’t figure out what the heck it is though. I’m going to be on vacation next week so I think I’ll just do a reinstallation on this computer then to get it all working the way it should be. :slight_smile:

Many thanks for all the help Malcolm! You’re the best!!!

Just wanted to post this in case others have the same lack of understanding of how Gnome works as me.

So the issue is actually just a settings change. One which I had changed in my initial VM test but had forgotten about. You can find the setting in Tweaks >> Top Bar. Just disable the “Application Menu” and then it pops up into the window itself.

I guess coming from “traditional” desktop environments there are a lot of things about Gnome that are kind of odd to me. Like having menus outside of the window. Lol.