Minecraft won't work (SLED 11 SP1)

Hello everyone,

I know that this is openSUSE forum and that openSUSE differs a bit from SLED, but I can’t get answer to my problem in SLED forums, so maybe you will be able to help me.

The thing is, something’s wrong with my java, I believe. I tried playing both, in browser and offline, same result (white or black screen after loading map). When I play version offline, I get hs_err_pid****.log (****-number) file after the map has been loaded. Terminal, however, says:

 Exception in thread "Minecraft main thread" java.lang.UnsatisfiedLinkError: Can't load library: /home/paulius/.minecraft/bin/natives/liblwjgl.so
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1706)
	at java.lang.Runtime.load0(Runtime.java:770)
	at java.lang.System.load(System.java:1003)
	at org.lwjgl.Sys$1.run(Sys.java:69)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)
	at org.lwjgl.Sys.loadLibrary(Sys.java:81)
	at org.lwjgl.Sys.<clinit>(Sys.java:98)
	at org.lwjgl.opengl.Display.<clinit>(Display.java:132)
	at net.minecraft.client.Minecraft.a(SourceFile:183)
	at net.minecraft.client.Minecraft.run(SourceFile:629)
	at java.lang.Thread.run(Thread.java:662)

What is annoying that I can’t even play it in browser, it just shows white screen. Therefore, I believe it’s something to do with java.
And yes, I have updated it to the very last version and java.com confirms it.

I would really appreciate help.


On 09/21/2011 04:06 PM, PauliusC wrote:
> Can’t load library: /home/paulius/.minecraft/bin/natives/liblwjgl.so

-=WELCOME=- new poster!!

i know nothing about Minecraft, but i do wonder why it is installed in
your /home, are you on a shared machine on which you don’t have the
rights necessary to install the application to the system (rather, than
to your home)??

anyway, does the above listed file exist?
is it readable by the application trying to read it?
is it executable by that application?

hmmmm…i think the main question is: How did you install Minecraft?
Specificially, did you follow the install instructions provided to you
by the seller of the application? If not, you need to precisely follow
their instructions and then if it doesn’t work you need to ask them
why not, and get their professional assistance and support for their

again WELCOME, if after consulting with the Minecraft maker/seller you
still need help from this community, please post to the games forum, for
it is there that gamers help gamers (at least, you might find some that
know something about the game, and maybe even faced the same
problem–you could search <http://forums.opensuse.org/search.php> that
forum <http://tinyurl.com/6arytvj> and see if it has already been solved…

and, please tell me why you “can’t get answer to my problem in SLED
forums” … you have a support contract, right??

openSUSE®, the “German Automobiles” of operating systems

Hello PauliusC,

The error states that it can’t find the file liblwjgl.so in /home/paulius/.minecraft/bin/natives/.
So the first thing you could do is look in that folder and see if that file is there or not.

This is how Minecraft works, you buy an account, download the launcher which is publicly available on the minecraft.net site.
When you run the launcher it will ask for your account’s name and password.

After that the launcher will check if there’s already a .minecraft folder in your home directory.
If not it will create it and download all the needed libraries and resources.

What you can try is rename the .minecraft folder (and make a backup) and then run the minecraft launcher.
It will download all the libraries again, including the one that it’s unable to load.

Did it work before on your installation?

Best of luck!:wink: