MINECRAFT JAVA EDITION on LAN: opensuse 15, not works

hi

i try connect minecraft to other computer inside my house: LAN, but maybe is blocked from firewall but how i want connect without problem…playing my daughters… i see firewall but there is not name: minecraft or java…
what i will do this for my daughters… playing minecraft use with two computer linux (opensuse 15.0 and opensuse 15.2 beta)…

thank you

Minecraft uses TCP 25565 for communication, so you’ll need to open that port in your firewall on the system where you are hosting the minecraft server on.

You can open a port in firewall’s public zone by issuing:

sudo firewall-cmd  --zone=public --add-port=25565/tcp

It will ask for your root password. See if this helps, if not - let’s try to debug why not.

ok i did comand firewall… but not works…nothing list of lan

Hi
Just tested here, minecraft server on Leap 15.1, client on Tumbleweed. Opening the port worked fine on the server side…

Can you confirm the rule on the server took, you might also want to switch to root user rather than sudo via su -


firewall-cmd  --list-all

public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth0
  sources: 
  services: ssh dhcpv6-client
  ports: 
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 
    
firewall-cmd  --zone=public --add-port=25565/tcp
success

firewall-cmd  --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth0
  sources: 
  services: ssh dhcpv6-client
  ports: 25565/tcp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

I ran the server in GUI mode…

Server:
https://forums.opensuse.org/attachment.php?attachmentid=895&stc=1

Firewall running on server no port open:
https://forums.opensuse.org/attachment.php?attachmentid=896&stc=1

Opened port:
https://forums.opensuse.org/attachment.php?attachmentid=897&stc=1

ok i try…

firewall-cmd  --list-all                 
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth0
  sources: 
  services: dhcpv6-client
  ports: 4644/tcp 4644/udp 25565/tcp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

gokuhh@localhost:~> firewall-cmd  --zone=public --add-port=25565/tcp
Warning: ALREADY_ENABLED: '25565:tcp' already in 'public'
success
gokuhh@localhost:~> firewall-cmd  --list-all
public (active)
  target: default
  icmp-block-inversion: no
  interfaces: eth0
  sources: 
  services: dhcpv6-client
  ports: 4644/tcp 4644/udp 25565/tcp
  protocols: 
  masquerade: no
  forward-ports: 
  source-ports: 
  icmp-blocks: 
  rich rules: 

on opensuse 15.2 beta minecraft: i go single player, open world, menu: open to lan,start lan world, output text message:local game hosted on port 33079.
on opensuse 15.0 minecraft: i go multiplayer:

screen shot here, how i put here image upload file…???

https://paste.opensuse.org/47356474

Hi
Did you add the server ip address to the client?

i try restart firewall but there isone list in search minecraft lan: LAN WORLD but error message: https://paste.opensuse.org/48480590

but i click REFRESH result list is empty…but i restart firewall and back the list but 2 seconds after is empty (refresh)…what is problem from…?
:open_mouth:

Hi
Did you check the firewall command again, since you restarted the firewall;


firewall-cmd  --list-all

I had to disable the firewall using

systemctl stop firewalld
systemctl disable firewalld

like "The authentication are currently down for maintenance" in Minecraft Java Edition when connecting to a LAN IP address - Arqade describes, then set the subnet mask of my static IP address to 255.255.255.0 rather than 255.255.255.255, so MINECRAFT JAVA EDITION on LAN: opensuse 15, not works... - #2 by Miuku is probably correct if your network configuration is too, @manuel_songokuh.