Microsoft Teams on OpenSUSE Leap ?


I’m running OpenSUSE Leap 15.1 on my workstation and my laptop. I got an offer to teach at a school here in South France, but they’re using Microsoft Teams for virtual classes.

I checked on the Microsoft Teams homepage, and there are two more or less distribution-agnostic download links, one for DEB and another one for RPM. The RPM link looks like a RHEL/CentOS repository to me.

Before I’m starting to experiment, I thought I’d rather ask in this forum. Has anyone gotten Microsoft Teams to work under OpenSUSE Leap ? Any caveats ?

Cheers from the sunny South of France.

You can download the rpm and install it with zypper. My daughter uses Teams for school and it works fine on Leap 15.1

Thank you very much !

Just in case this thread is of value to you regarding getting the camera working with Teams…

I started to use it in my little teaching job, as the school had arranged this. OpenSuse Leap 15.1, the rpm of Teams. Things were fine at first, then something happened. The whole system would freeze, without Teams being in use. No way but reset to get the system up again, and at some point it refused to boot. A day later it booted again, normally, but the freezing kept on. I got rid of the Teams app, and the freezing stopped… for a while. Now it happens again, as far as I can tell only when multimedia stuff (films, YouTube, but not music) is running. I suspected Firefox, but it happens with Falkon too. Significantly (?), the freezes do not occur as often as with the Teams app present, but I suspect something else is playing up. I have only 15.1, no other system. All of this is happening on a stand-alone system, with an SSD hard disk. In the beginning, the first few months of 15.1 showed no problems with the system. The same system is installed on a Lenovo Ideapad, and there are no freezes there; I have not dared to install the Teams app on that, and the Firefox extensions are even fewer. I suspect I have installed something on the big machine which I should not have, for whatever reason, but I do not know yet what.

So Teams seems okay, but there it is. It may actually cause instability, but I don’t think so. All that is little help, I realise, but might be paralleled in someone else’s experience.

What video card and driver???

The info I have from KDE-Infocentre is AMD Kaveri Radeon R5 Graphics, DRM 2.50.0, 4.12.14-lp151.28.48-default, Open GL version 4.5 (Compatability Profile) Mesa 18.3.2.

If that helps - and if it is the information you need.

Having managed to get what brain I have to work, I checked using YAST too. ATI Kaveri, Radeon 5, radeon driver.

Are you using Btrfs on the system partition?
And, also on the user partition(s)?
[HR][/HR]If yes, then this “How-To” post: <>.And, with the user “root” – “systemctl start btrfs-balance.service”
When it has completed: “systemctl start btrfs-scrub.service”
And, when that’s completed: “systemctl start btrfs-defrag.service”

That is impressive. Yes, Btrfs on, well, the only partition for files and that. There is a Grub, a main, and a swap partition.

Have attempted to do as instructed. Shall wait and see whether I have done so correctly (having virtually no idea about this, I may, as so often, be the major problem myself). I shall report back in a while. Thank you very much for your kind help thus far!

OK, first couple of hours, no freezes. Cannot log into OpenSuse Forums on Firefox, but that is surely some other weird problem. Using Falkon, there is no problem with log-in. Otherwise - no freezes so far. I am wondering whether I dare install Teams again…

If something happens - or if it does not - I shall report. Again, many thanks for this unbelievably quick (and I dare say accurate, spot-on) help!

Please make sure that, as per the “How-To”, ensure that:

  1. The Btrfs Balance, Scrub and Defrag systemd timer services are enabled
    . 1. The “btrfsmaintenance-refresh.path” systemd service is enabled
    . 1. The “btrfsmaintenance-refresh.service” systemd service is disabled

Have you, possibly, added at least one Test repository which looks something like this?

  • “zypper repos --uri”
28 | repo-update-test | Ungetestete Aktualisierungen | Yes | (r ) Yes | Yes | 99 | rpm-md |

If yes, then, remove all such repositories and then:

  • “zypper dup --from repo-update”
  • And, if you’re using the Packman repositoriy: “zypper dup --from Packman”

Assuming that, Btrfs is behaving and, you haven’t included any “Test” repositories, I suspect that, there won’t be any issues which arise from that.

Not being the sharpest knife in the drawer, I failed to notice a Teams repository still there. I have removed it.

OK - had a freeze again before that. But this is because I fail to understand how to change the state of btrfsmaintenance-refresh.service. I have never done anything like that before, and clearly I do not know how, although I should. I did say I myself am probably the root of most problems…
So I get stuck when I reach nano. (I hate to bother you with stupid things like this, but there it is. Apologies!)

Well, reflected a while on my own stupidity and tried YAST, and lo! It looks as though I have reset things now to where you have recommended.
I shall test by rebooting, and with luck I have not mucked everything up.

Ah, yes, well, YAST was not the right thing it seems. Probably because we are talking about .path on the one hand and .service on the other? At any rate, via YAST services admin I (seemingly) disabled .service as advised. Right, that was not really so good, so reset things the way they were, and the machine (or the system) REALLY didn’t like all this faffing about, and reboot failed (could not load ramdisk). Tried USB 15.1, but nothing there would work either! Turned the computer off, set up the laptop, did stuff. Hours later, decided to see - and sure enough, now the computer rebooted. Some rollercoaster!
Let this be a warning to anyone like me… If someone could be kind and patient enough to tell me how to disable the .service in console I would be grateful. As it is, I have this feeling of just not having done my homework (and being rather busy otherwise, so it is not too easy).
I knew I was the biggest problem my computer has.

A couple of useful systemd references:

Finally I’ve got it. At least, refresh.service is disabled and refresh.path is enabled. It was the systemd documentation that put me on the right track, very many thanks for that.

I would like to say to any and all critics of these forums that they are wrong if they ever say there is no help. I have received such excellent help here, and that although I clearly do not have the expertise I should have, and my problem was doubtless at least as much down to my not knowing enough as to any possible bug.

Thanks to all here who have helped. I shall now see whether the freeze problem has been abolished (if not, it’s because I have done something wrong - that is the nice part, the user always knows whose fault it basically is).

Steps taken: console, carried out systemctl disable btrfsmaintenance-refresh.service. (as normal user, had to give password, would have been easier as su I guess, but no matter)
Checked with systemctl list-unit-files btrfsmaintenance-refresh.*
Both were now disabled.
Proceeded with systemctl reenable btrfsmaintenance-refresh.path.
Checked as above, now path was enabled, service disabled.
Carried out “systemctl start btrfs-balance.service”, “systemctl start btrfs-scrub.service”, “systemctl start btrfs-defrag.service” as instructed. Nothing seemed to happen.
Rebooted, then checked with systemctl list-units --all btrfsmaintenance-refresh.*
path is loaded, active, service is loaded, inactive.

It seems to have gone off perfectly, and (for me) in a less complicated way than described in the SDB Fix btrfsmaintenance-refresh. I shall find out whether I have mucked everything up (after all, if it can be broken, I’m the one who will do it).:slight_smile:

Enabling and disabling systemd services is described here: <>.
Doing it with YaST is described here: <>.
[HR][/HR]Despite the handbook references, it’s actually quite simple:

  • With the user “root” and a CLI: “systemctl enable btrfsmaintenance-refresh.path” and “systemctl disable btrfsmaintenance-refresh.service”.

You need to use “systemctl status btrfs-balance.service”, “systemctl status btrfs-scrub.service” and “systemctl status btrfs-defrag.service” to check whether or not the Btrfs Balance/Scrub/Defrag services are still executing or, if they’ve completed.
The CLI command “top” will also indicate if a process with the name “btrfs” is executing, or not.

Ah, I have learnt something. That bit about… having not done that, a freeze occurred. Well, have finally found the funny little editor that shows up after the command ‘edit’, somehow stumbled on to the right way to do it (good thing all of this stuff is battle-hardened), have rebooted and applied those three commands. Freezes should now be a thing of the past.

Unless I have done it wrong - I don’t think so, followed the instructions to a t, but with me…

Anyhow, I hope to be able to leave this thread, and everyone, in peace now. Many, many thanks for the very great and patient help, particularly to dcurtisfra and deano_ferrari. Again, I think the help here is enormous, and the people offering it are being really, really nice.:slight_smile: