Microsoft lifecam Vx-3000 webcam - HELP

I’m a new user to Linux and openSUSE, and I cannot get my web-cam to work.
I’m running OpenSUSE 11.1 and:

uname -a:

Linux linux-e696 #1 SMP 2009-05-26 17:02:05 -0400 i686 i686 i386 GNU/Linux 


Bus 007 Device 009: ID 045e:00f5 Microsoft Corp. LifeCam VX-3000

Skype and kopete do not detect any webcams.

Searching through the forums I tried to install gspca but came across the error when using YaST:

nothing provides kernel(default:drivers_usb_core) = 4460f5d7752dd946 needed by gspcav1-kmp-default-20071224_2.6.25.5_1.1-10.4.i586

I tried to install gspca by downloading from ~jfrancois/gspca: Summary](, but when I ./config_build I get the errors:

 REMOVE the old module if present                                                   
ERROR: Module gspca does not exist in /proc/modules                                 

 CLEAN gspca source tree                                                            
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \                              
        .gspca.o.cmd  *.o *.ko *.mod.* .[a-z]* core *.i \                           
        *.symvers *.err                                                             

 COMPILE gspca Please Wait ....!!                                                   

 INSTALL gspca in the kernel binary tree                                                   
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/                                 
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko                          
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko                          
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/              
install: cannot stat `gspca.ko': No such file or directory                                 
make: *** [install] Error 1                                                                

 LOAD gspca in memory                                                                      
FATAL: Module gspca not found.                                                             

 PRINT COMPILATION MESSAGES if ERRORS look kgspca.err                                      
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/Ben/Desktop/gspcav1-20071224 CC=cc modules                                                                                        
make[1]: Entering directory `/usr/src/linux-'                
make -C ../../../linux- O=/usr/src/linux- modules                                                                                        
  CC [M]  /home/Ben/Desktop/gspcav1-20071224/gspca_core.o                                  
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory                                                                              
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c: At top level:
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
/home/Ben/Desktop/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
make[4]: *** [/home/Ben/Desktop/gspcav1-20071224/gspca_core.o] Error 1
make[3]: *** [_module_/home/Ben/Desktop/gspcav1-20071224] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-'
make: *** [default] Error 2

Another forum said to install lib4l (which I did in YaST and from v4l-dvb: Summary) then do:

LD_PRELOAD=/usr/lib/libv4l/ skype 

I don’t get any errors but skype still does not detect any web-cam. I’m getting frustrated. If I cant fix this, can anyone tell me what webcam to buy that will work.

For viewing have you tried video4linux or video4linux2 - different webcams work on each version.

You can use aMSN to communicate via MSN.

(Thanks to Martin Ranyard for those tips).

you need to be greatly commended for the amount of work that you have done on your own to:
research and then try to resolve this issue:

from this website

MicroSoft 229 0x045e 0x00F5 VX3000 sn9c105r OV7660 Yes Jpeg gspcav1 ***

your camera is gspca … and the drivers were put into the 2.6.27 kernel … and it … should work …but does not

you ask what cameras do work?

Well, it is said that UVC cameras do; (out of the box …)

and this website

Linux UVC driver & tools

lists them …

but buyer beware …

… some say webcams are cheap so just buy a new one, and … hopefully … a UVC compliant webcam will work

vx 3000 runs fine with the GSPCA v2 driver module. it must replace the old gspca_sonixj with the one published on the web. I can’t find any kmp RPM for the moment…
this 2nd version of the driver for v4l2 which compiles on 2.6.30 kernel at least.
GSPCA V4L2 - Webcams

Skype runs fine by adding


at startup (skype may be rebooted once or twice to work).

Wow ! I’ve reached to the end of gspca v4l2 packaging. Available for install on 11.2. plz report any bug !
I’ll make install tests tomorrow with my own cam…:wink:

Did you know that the sonixj will work in I have been waiting for the kernel update. I’m running the later kernel on a test machine using Factory. The VX-3000 is plug & play with that kernel