Microphone not working on Toshiba A200 laptop with snd_hda_intel driver


I tried adjusting the different levels with alsa-mixer and recording with arecord, but I can’t seem to make my built in microphone work. I tried adding model=toshiba to the relevant modprobe.d file.

Anybody know a solution?

/usr/sbin/alsa-info.sh gives me this output:

Thansks in advance,


Did you try Pulse Audio?

How can I do that??

Just install it :

zypper in pulseaudio


Did you try recording with an external headset plugged into a jack on the mic? Or is this the integrated mic you are trying to use?

I note this from the diagnostic script:


**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
Which tells me ALSA has configured for one mic device only. Is that consistent with your hardware that you can see with your eyes ? ie there is no internal integrated mic ? But there may be two jacks for a mic ? (ie one on side and one in back of laptop ) ?

I notice this from the script as well:

!!Amixer output

!!-------Mixer controls for card 0 [Intel]

Card hw:0 ‘Intel’/‘HDA Intel at 0xfc500000 irq 32’
Mixer name : ‘Realtek ALC268’
Simple mixer control ‘Front Mic Boost’,0
Front Left: 0 [0%]
Front Right: 0 [0%]
Simple mixer control ‘Mic Boost’,0
Front Left: 2 [100%]
Front Right: 2 [100%]
Simple mixer control ‘Capture’,0
Front Left: Capture 31 [100%] [30.00dB] [on]
Front Right: Capture 31 [100%] [30.00dB] [on]
Simple mixer control ‘Digital’,0
Front Left: Capture 120 [100%] [30.00dB]
Front Right: Capture 120 [100%] [30.00dB]
If you are plugging your external mic into the “front jack” then the boost is at zero and it may not record. You may need to move up the “front jack” boost in your mixer in such a case.

Intalled pulseaudio and enabled it using sudo setup-pulseaudio --enable

Nothing changed - I tried maxing the level on all available audio channels, but I am still not able to record anything:-(

No external mic at all - only one built in mic that i try to use with no luck. I tried maxing all channels and recording but it didn’t help me.

Thanks for your effort, but ir didn’t solve my problem unfortunately.

I note an ALC268 in that Toshiba A200.

Did you try going to the alsa web site to see if there were any updates to the ALC268 ?

I just did and there are: Search results - AlsaProject

I note:

# Changes v1.0.22 v1.0.23 (266,921 bytes)
314: : ALSA: hda - **Fix wrong model range check for ALC268**
344: : ALSA: hda - Remove the COEF setup for ALC267/ALC268
2815: : - ALSA: hda - Fix wrong model range check for ALC268
2818: : the upper-limit in parse_alc268(), so that any wrong value can't be
3019: : - ALSA: hda - Remove the COEF setup for ALC267/ALC268 

Hence its possible the default model is wrong.

Reference enabling in pulse, frankly IMHO that will just make things worse. IF it did not work, undo what you did there.

Reference the model you applied, according to the linlap site, if you are going to apply a model option then the one you applied is wrong. Toshiba Satellite A200 [LinLap - Linux Laptop Wiki]

Linlap suggests applying the model=3stack option. (try that and then restart to test).

Frankly, even that may not do the trick, and you may need to update to a cutting edge alsa to obtain the fix I quoted above. If you wish to try that, let me know and I can point you to a guide on how to update alsa via rpm (as there are updated alsa rpms on a special repository maintained by the openSUSE alsa sound packager).

I managed to remove pulseaudio again.

I now tried several times with model= toshiba, 3stack and lenovo added to /etc/modprobe.d/50-sound.conf with no luck. I am restarting alsa inbetween.

I took a look in the ALSA changelogs. Maybe I should try the latest ALSA. Could you point me on how to do it…? Thanks for your help.

There is guidance here on this wiki on how to install rpms with a very cutting edge version of ‘alsa’. SDB:Alsa-update - openSUSE

Do not let the alsa version number (1.0.23) fool you. That page DOES provide an update of alsa that is newer than the version 1.0.23 of alsa that comes with openSUSE.

That wiki is in need of update (my fault its out of date). So a couple of points. … Don’t let the slight staleness in kernel version numbers mislead you. You need to ensure that your kernel version is consistent with the alsa-driver-kmp-<kernel> rpm that you install (and not so much the “title label” on the wiki guide).

Also, when you install the variou alsa apps, such as alsa, alsa-tools, alsa-plugins, alsa-utils, libasound2, etc … please ensure you actually update. Check your alsa application version numbers BEFORE and AFTER you update. The version numbers should change !! Pay close attention to the example screen shots on that update page, as they point out where you MUST check to ensure you select the appropriate alsa updated applications from the multimedia repository. If you do not do that, you will fail to update alsa, and hence the problem you are encountering may not be solved.

Good luck.